Ladehemmungen mit PHP 5.2.11

07/11/2009 - 22:43 von Thomas Steinbach | Report spam
Hallo,

nach einer Standardinstallation von PHP 5.2.11
fuer einen Apache 2.2.14 (alles Standardpfade) sind einige
Module vorkonfiguriert. Allerdings startet meine Apache nur,
wenn diese Module:

;extension=php_oci8.dll
;extension=php_pdo_oci.dll
;extension=php_pdo_oci8.dll
;extension=php_pdo_sqlite_external.dll
;extension=php_sybase_ct.dll

auskommentiert sind. Warum?

Sollte das nicht funktionieren, wenn der Installer das doch
so "ausgewaehlt" hat oder sind diese Module einfach buggy?
Wobei ich mir bei Oracle sowas gerade nicht so recht
vorstellen kann.

btw: Warum startet der Apache eigentlich nicht und laesst
diese Module einfach ungeladen, statt eben nicht zu starten?

Thomas
 

Lesen sie die antworten

#1 Carsten Wiedmann
07/11/2009 - 23:11 | Warnen spam
Thomas Steinbach schrieb:
nach einer Standardinstallation von PHP 5.2.11
fuer einen Apache 2.2.14 (alles Standardpfade) sind einige
Module vorkonfiguriert. Allerdings startet meine Apache nur,
wenn diese Module:

;extension=php_oci8.dll
;extension=php_pdo_oci.dll
;extension=php_pdo_oci8.dll
;extension=php_pdo_sqlite_external.dll
;extension=php_sybase_ct.dll

auskommentiert sind. Warum?




Diese Extensions (und manch andere) benötigen weitere externe DLL's, welche
bei PHP nicht dabei sind. (siehe dazu auch das Kapitel Installation im PHP
Manual zu den Extensions)

btw: Warum startet der Apache eigentlich nicht und laesst
diese Module einfach ungeladen, statt eben nicht zu starten?



Eine Software welcher benötigte DLLs fehlen, startet nicht...


Gruß
Carsten

Ähnliche fragen