Lagerliste

28/05/2010 - 10:42 von Kassandra34 | Report spam
Hallo,

versuche gerade eine Lagerbestandsliste im Excel aufzubauen, folgendes
Problem hindert mich:

Tabelle Lagerbestand:

Datum Artikel EK-Preis
03.12.09 AZB "gesucht"

Im Blatt "Preisliste" sind die EK-Preise hinterlegt, die per Datum für
den gleichen Artikel variieren. (Per Spalte: 1. Spalte Gültig ab / 2.
Spalte Gültig bis)

Ich möchte eine Formel erstellen, die:

wenn das Datum (aus Lagerliste) zwischen zwei Daten (aus Preisliste)
zugehörig zu dem gesuchten Artikel (steht in Lagerliste und in
Preisliste) liegt, dann gib den passenden Preis wieder.

Ist bestimmt ganz einfach - nur für mich nicht - ich werd noch
verrückt!

Bitte helft mir!

Danke
 

Lesen sie die antworten

#1 Stefan Kunze
28/05/2010 - 19:59 | Warnen spam
Hallo Kassandra34,

"Kassandra34" schrieb
Hallo,

versuche gerade eine Lagerbestandsliste im Excel aufzubauen, folgendes
Problem hindert mich:

Tabelle Lagerbestand:

Datum Artikel EK-Preis
03.12.09 AZB "gesucht"

Im Blatt "Preisliste" sind die EK-Preise hinterlegt, die per Datum für
den gleichen Artikel variieren. (Per Spalte: 1. Spalte Gültig ab / 2.
Spalte Gültig bis)

Ich möchte eine Formel erstellen, die:

wenn das Datum (aus Lagerliste) zwischen zwei Daten (aus Preisliste)
zugehörig zu dem gesuchten Artikel (steht in Lagerliste und in
Preisliste) liegt, dann gib den passenden Preis wieder.

Ist bestimmt ganz einfach - nur für mich nicht - ich werd noch
verrückt!



Naja, einfach ist rellativ ;-)
Wenn deine Tabelle Lagebestand so aussieht:
A B C
Datum Artikel EKP
01.03.2010 Artikel1 30
18.03.2010 Artikel1 30
04.04.2010 Artikel1 40
21.04.2010 Artikel1 40
08.05.2010 Artikel1 50
25.05.2010 Artikel1 50
11.06.2010 Artikel1 60

und deine Preisliste so:
A B C D
Dat von Dat bis Artikel EKP
01.01.2010 31.01.2010 Artikel1 10
01.02.2010 28.02.2010 Artikel1 20
01.03.2010 31.03.2010 Artikel1 30
01.04.2010 30.04.2010 Artikel1 40
01.05.2010 31.05.2010 Artikel1 50
01.06.2010 30.06.2010 Artikel1 60
01.07.2010 31.07.2010 Artikel1 70
01.08.2010 31.08.2010 Artikel1 80
01.09.2010 30.09.2010 Artikel1 90
01.10.2010 31.10.2010 Artikel1 100
01.11.2010 30.11.2010 Artikel1 110
01.12.2010 31.12.2010 Artikel1 120

Muss die Formel in der Tabelle Lagerbestand Zelle C2 so lauten:

=SUMMENPRODUKT(1*(A2>=Preisliste!$A$2:$A$20);
1*(A2<=Preisliste!$B$2:$B$20);
1*(B2=Preisliste!$C$2:$C$20);
Preisliste!$D$2:$D$20)

Ohne Zeilenumbruch natürlich.
Die Formel prüft drei Kriterien:
1. ist Datum größer oder gleich DatumAb aus Preisliste
2. ist Datum kleiner oder gleich DatumBis aus Preisliste
3. Stimmt der Artikelname überein

Wenn dreimal WAHR gefunden wird, liefert die Formel den Preis, sonst 0.

Viele Grüße
Stefan

Ähnliche fragen