Lange Formel kann nicht aufgezeichnet werden - Wie bekommt man es doch hin?

14/06/2008 - 17:37 von Walter Heying | Report spam
Hallo,

ich habe eine Personalplandatei erstellt. Diese làuft nun einwandfrei.
Ich habe jedoch sehr viele Formel, die auch noch sehr lang sind.
Beispiel:
=WENN(ODER($B10="-";CQ
$3="";ISTFEHLER(BEREICH.VERSCHIEBEN(Personalfeinplanung!$A
$2;VERGLEICH(CQ$3;BEREICH.VERSCHIEBEN(Personalfeinplanung!$A
$2;$A10;$B10-1):BEREICH.VERSCHIEBEN(Personalfeinplanung!$A
$2;$A10+95;$B10-1);0)-1+
$A10;$B10+1)));"";WENN(BEREICH.VERSCHIEBEN(Personalfeinplanung!$A
$2;VERGLEICH(CQ$3;BEREICH.VERSCHIEBEN(Personalfeinplanung!$A
$2;$A10;$B10-1):BEREICH.VERSCHIEBEN(Personalfeinplanung!$A
$2;$A10+95;$B10-1);0)-1+
$A10;$B10+1)="";WENN(BEREICH.VERSCHIEBEN(Personalfeinplanung!$A
$2;VERGLEICH(CQ$3;BEREICH.VERSCHIEBEN(Personalfeinplanung!$A
$2;$A10;$B10-1):BEREICH.VERSCHIEBEN(Personalfeinplanung!$A
$2;$A10+95;$B10-1);0);$B10);
$B10;WENN(ISTFEHLER(VERGLEICH(FT10;$E10:$J10;0));"";LINKS(BEREICH.VERSCHIEBEN($E
$3;0;VERGLEICH(FT10;$E10:$J10;0)-1);
1)));BEREICH.VERSCHIEBEN(Personalfeinplanung!$A$2;VERGLEICH(CQ
$3;BEREICH.VERSCHIEBEN(Personalfeinplanung!$A
$2;$A10;$B10-1):BEREICH.VERSCHIEBEN(Personalfeinplanung!$A
$2;$A10+95;$B10-1);0)-1+$A10;$B10+1)))
Nun möchte ich diese Formel vba übersetzen. Bisher habe ich immer den
Makro-Rekorder genutzt. Teilweise kam auch dort schon die Meldung:
Formel kann nicht aufgezeichnet werden. Ich habe dann die Formel
geteilt, aufgezeichnet und anschließend die Teilformeln in VBA wieder
zusammen gebracht. Bei dieser Formel gelingt mir die Trennung in
sinnvolle Teilformeln nicht.
@@@@ Gibt es eine Möglichkeit die Formel trotzdem ins VBA zu bringen?

Gruß
Walter
 

Lesen sie die antworten

#1 Peter Schleif
14/06/2008 - 17:53 | Warnen spam
Walter Heying schrieb am 14.06.2008 17:37 Uhr:

ich habe eine Personalplandatei erstellt. Diese làuft nun einwandfrei.
Ich habe jedoch sehr viele Formel, die auch noch sehr lang sind.
Nun möchte ich diese Formel vba übersetzen.



Wenn sie in der Tabelle doch schon funktionieren, brauchst Du sie doch
nicht nochmal aufzeichen. Lasse sie dir doch einfach direkt in VBA
anzeigen:

MsgBox [A1].Formula '/Englisch bzw Original/
MsgBox [A1].FormulaLocal '/Deutsch/

Peter

Ähnliche fragen