Lange "ODER" "WENN" Formel

02/07/2008 - 13:53 von Sarah | Report spam
Hallo zusammen,

ich habe die folgende Formel, um mir am Anfang der Tabelle die
Ergebnisse vom hinteren Teil anzeigen lassen zu können, ohne lange
scrollen zu müssen:

=ODER(WENN(DC2494:DF2494="P";"P";" ");WENN(DC2494:DF2494="x";"OK";"
");WENN(DC2494:DF2494="NOK";"NOK";" ");WENN(DC2494:DF2494="NT";"NT";"
"))

P soll ein P reingeschrieben werden
x soll ein OK reingeschreiben werden
NOK soll ein NOK reingeschrieben werden
und bei NT soll vorn ein NT reingeschrieben werden

Ich hatte das so wie es ist nur mal mit dem "x Fall" versucht und hier
auch nur eine einzige Zelle auswerten lassen (ohne ODER) und da hatte
es geklappt. Wenn ich mehrere Zellen will ":" dann geht es schon mal
nicht mehr und ich bekomme #Wert.
Jetzt habe ich das selbe Problem und weiß nicht woran es liegen
könnte.

Kann mir hier jemand weiterhelfen?

Danke & Gruß
Sarah
 

Lesen sie die antworten

#1 Wolfgang Habernoll
02/07/2008 - 18:09 | Warnen spam
Hallo Sarah

"Sarah" schrieb im Newsbeitrag news:
Hallo zusammen,

ich habe die folgende Formel, um mir am Anfang der Tabelle die
Ergebnisse vom hinteren Teil anzeigen lassen zu können, ohne lange
scrollen zu müssen:

=ODER(WENN(DC2494:DF2494="P";"P";" ");WENN(DC2494:DF2494="x";"OK";"
");WENN(DC2494:DF2494="NOK";"NOK";" ");WENN(DC2494:DF2494="NT";"NT";"
"))

P soll ein P reingeschrieben werden
x soll ein OK reingeschreiben werden
NOK soll ein NOK reingeschrieben werden
und bei NT soll vorn ein NT reingeschrieben werden

Ich hatte das so wie es ist nur mal mit dem "x Fall" versucht und hier
auch nur eine einzige Zelle auswerten lassen (ohne ODER) und da hatte
es geklappt. Wenn ich mehrere Zellen will ":" dann geht es schon mal
nicht mehr und ich bekomme #Wert.
Jetzt habe ich das selbe Problem und weiß nicht woran es liegen
könnte.



versuche es mal so, {
=WENN(UND(DC2494:DF2494="P");"P";WENN(UND(DC2494:DF2494="x");"OK";WENN(UND(DC2494:DF2494="NOK");"NOK";WENN(UND(DC2494:DF2494="NT");"NT";""))))
}

auf ODER kannst du verzichten, braucht aber ein paar UND. Es ist als Matrixformel einzugeben also { } nicht mitkopieren sondern die
Eingabe mit "Strg+Shift+Enter" abschließen.

mfG
Wolfgang Habernoll

[ Win XP Home SP-2 , XL2002 ]

Ähnliche fragen