Forums Neueste Beiträge
 

Langsames Cryptodevice

18/10/2012 - 10:50 von Holger Marzen | Report spam
Gegeben:
- PC mit Core i5
- SSD Crucial m4
- Ubuntu 11.10 mit Kernel 3.0
- Installation auf LVM auf LUKS-Device

Lesen von der SSD geht fix:
root@regen:~# hdparm -tT /dev/sda
/dev/sda:
Timing cached reads: 13862 MB in 1.99 seconds = 6956.94 MB/sec
Timing buffered disk reads: 1104 MB in 3.00 seconds = 367.43 MB/sec <
Lesen vom Cryptodevice bricht deutlich ein:
root@regen:~# hdparm -tT /dev/mapper/sda5_crypt
/dev/mapper/sda5_crypt:
Timing cached reads: 14492 MB in 1.99 seconds = 7272.60 MB/sec
Timing buffered disk reads: 266 MB in 3.02 seconds = 88.02 MB/sec <
CPU kann AES
Kernel-Config:
root@regen:/boot# grep -i aes config-3.0.22
CONFIG_SND_MAESTRO3=m
CONFIG_SND_MAESTRO3_INPUT=y
CONFIG_CRYPTO_AES=y
CONFIG_CRYPTO_AES_X86_64=m
CONFIG_CRYPTO_AES_NI_INTEL=m
CONFIG_CRYPTO_DEV_PADLOCK_AES=m

AES-Module sind nicht geladen:
root@regen:/boot# lsmod | grep -i aes
root@regen:/boot#

Lade ich die Module, gibt es keine Verbesserung des Durchsatzes:
root@regen:/boot# lsmod | grep -i aes
aesni_intel 55539 0
cryptd 20360 1 aesni_intel
aes_x86_64 17208 1 aesni_intel

Ideen, wieso das Cryptodevice so langsam ist?
Beim hdparm aufs Cryptdevice hab ich ca. 40% CPU-Auslastung.
 

Lesen sie die antworten

#1 ds_Dieter_Schultheis
20/10/2012 - 07:43 | Warnen spam
Am 18.10.2012 10:50, schrieb Holger Marzen:
Gegeben:
- PC mit Core i5
- SSD Crucial m4
- Ubuntu 11.10 mit Kernel 3.0
- Installation auf LVM auf LUKS-Device

Lesen von der SSD geht fix:
:~# hdparm -tT /dev/sda
/dev/sda:
Timing cached reads: 13862 MB in 1.99 seconds = 6956.94 MB/sec
Timing buffered disk reads: 1104 MB in 3.00 seconds = 367.43 MB/sec <>
Lesen vom Cryptodevice bricht deutlich ein:
:~# hdparm -tT /dev/mapper/sda5_crypt
/dev/mapper/sda5_crypt:
Timing cached reads: 14492 MB in 1.99 seconds = 7272.60 MB/sec
Timing buffered disk reads: 266 MB in 3.02 seconds = 88.02 MB/sec <>
CPU kann AES
Kernel-Config:
:/boot# grep -i aes config-3.0.22
CONFIG_SND_MAESTRO3=m
CONFIG_SND_MAESTRO3_INPUT=y
CONFIG_CRYPTO_AES=y
CONFIG_CRYPTO_AES_X86_64=m
CONFIG_CRYPTO_AES_NI_INTEL=m
CONFIG_CRYPTO_DEV_PADLOCK_AES=m

AES-Module sind nicht geladen:
:/boot# lsmod | grep -i aes
:/boot#

Lade ich die Module, gibt es keine Verbesserung des Durchsatzes:
:/boot# lsmod | grep -i aes
aesni_intel 55539 0
cryptd 20360 1 aesni_intel
aes_x86_64 17208 1 aesni_intel

Ideen, wieso das Cryptodevice so langsam ist?
Beim hdparm aufs Cryptdevice hab ich ca. 40% CPU-Auslastung.



Was für ein I5?

Wie stark ist dieser ausgelastet?

Wie voll ist der RAM Speicher?


MfG
Dieter

Ähnliche fragen