Forums Neueste Beiträge
 

Leere Zelle mit WENN(...) erzeugen

18/06/2008 - 07:51 von Thomas Mangold | Report spam
Hallo ich habe folgendes Problem:

Folgende Formel soll mir die Summe der Spalte C berechnen, wenn der Wert
in der Spalte B mit dem in Zelle A1 überinstimmt:
{=SUMME((A1=B$1:B$71)*(C$1:C$71))}

Das funktioniert solange C leer ist oder in ihr eine Zahl steht.

Der Wert in C ist aber eine Berechnung:
=WENN(REST(D1;2)=1;"";D1)

Frage:
Was muss ich statt "" in die Bedingung einfügen, damit das Feld so
behandelt wird als wenn es leer wàre?

Hinweis:
0 möchte ich nicht haben, weil aus der Spalte noch der Mittelwert
berechnet wird.

Die Lösung mit SUMMEWENN möchte ich auch nicht, da die Formeln etwas
komplexer sind.

Gruß
Thomas

Excel 2000
Win XP
 

Lesen sie die antworten

#1 Wolfgang Habernoll
18/06/2008 - 09:37 | Warnen spam
Hallo Thomas

"Thomas Mangold" schrieb im Newsbeitrag
news:g3a7p0$hou$03$
Hallo ich habe folgendes Problem:

Folgende Formel soll mir die Summe der Spalte C berechnen, wenn der Wert in
der Spalte B mit dem in Zelle A1 überinstimmt:
{=SUMME((A1=B$1:B$71)*(C$1:C$71))}

Das funktioniert solange C leer ist oder in ihr eine Zahl steht.

Der Wert in C ist aber eine Berechnung:
=WENN(REST(D1;2)=1;"";D1)

Frage:
Was muss ich statt "" in die Bedingung einfügen, damit das Feld so behandelt
wird als wenn es leer wàre?

Hinweis:
0 möchte ich nicht haben, weil aus der Spalte noch der Mittelwert berechnet
wird.

Die Lösung mit SUMMEWENN möchte ich auch nicht, da die Formeln etwas komplexer
sind.



was ist soo komplex an Summewenn, versuche es doch mal damit.
=SUMMEWENN(B1:B10;"="&A1;C1:C10)

damit sollte auch dein Mittelwert klappen da dieser die "" aus deiner Formel
berücksichtigt.

mfG
Wolfgang Habernoll

[ Win XP Home SP-2 , XL2002 ]

Ähnliche fragen