libtool hängt

02/01/2009 - 16:03 von Bernd Giesen | Report spam
Hallo,

ich habe ein Problem mit libtool beim Linken. Vielleicht kann mir ja hier
jemand weiterhelfen:

Die Vorgeschichte:
Ich habe auf meinem neuen Rechner openSuSE 11.1 mit KDE 4.1 installiert.
Unmittelbar nach dieser "Standardinstallation" konnte ich eine kleine, in
C++ geschriebene Konsolenanwendung (die ich bisher unter openSuSE 10.3/KDE
3.5.10 problemlos gepflegt hatte) einwandfrei compilieren und linken.
Leider benötige ich aber auch unter KDE 4.1 weiterhin kdevelop, was aber
bei der Installation von KDE 4.1 nicht mit installiert wurde. Also habe ich
kdevelop 3.x und alle dazu notwendigen Pakete brav über YAST
nachinstalliert.

Seitdem habe ich jedoch das Problem, dass libtool beim Linken meiner o.g.
Konsolenanwendung offensichtlich in einer Endlosschleife hàngenbleibt
(diese Konsolenanwendung habe ich bisher immer als kdevelop (3.x)-Projekt
ohne Probleme gepflegt).

Erstelle ich dagegen testhalber mit Hilfe von kdevelop eine neue, jetzt aber
cmake-basierte Konsolenanwendung, funktioniert alles wunderbar.

Kann mir jemand einen Hinweis geben, warum libtool jetzt plötzlich solche
Zicken macht? :-(((

gruß,
Bernd
 

Lesen sie die antworten

#1 Markus Raab
02/01/2009 - 16:53 | Warnen spam
Bernd Giesen wrote:

Seitdem habe ich jedoch das Problem, dass libtool beim Linken meiner o.g.
Konsolenanwendung offensichtlich in einer Endlosschleife hàngenbleibt
(diese Konsolenanwendung habe ich bisher immer als kdevelop (3.x)-Projekt
ohne Probleme gepflegt).



Verwendest du noch die gleiche libtool Version?

Der Linker (ld) bleibt hàngen? Kann ich mir schwer vorstellen, bitte Output
von dem Durchlauf.

Erstelle ich dagegen testhalber mit Hilfe von kdevelop eine neue, jetzt
aber cmake-basierte Konsolenanwendung, funktioniert alles wunderbar.



Du musst schon eine libtool basierte Konsolenanwendung erstellen um etwas
Vergleichbares zu bekommen.

Kann mir jemand einen Hinweis geben, warum libtool jetzt plötzlich solche
Zicken macht? :-(((



Mehr Infos bitte :-)

mfg Markus

Ähnliche fragen