D-Link W-Lan USB Stick unter SuSe Linux 11.0

15/07/2008 - 14:11 von Daniel Walz | Report spam
Hallo,

ich versuche, o.g. USB-W-Lan-Stick unter SuSe zum Laufen zu bringen.

Eine gute Anleitung habe ich unter
http://weblog.christoph-probst.com/...2153533359
gefunden, allerdings für Ubuntu.

Nachdem dort unter [update] steht:
"Der Treiber rt2x00 wird in Kernel 2.6.24 aufgenommen. Zukünftig dürfte
es deutlich leichter werden, diesen USB-WLAN-Stick einzusetzen."

habe ich mir jetzt SuSe-Linux 11.0 besorgt und gehofft, dass es
vielleicht automatisch erkannt würde, aber Fehlanzeige.

Leider verstehe ich nicht ganz, wo der Haken ist oder ich suchen soll
(bin Linux-Neuling).

Beim Booten wird der Stick scheinbar erkannt:

<6>usb 2-3: New USB device found, idVendord1, idProduct=3c03
<6>usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
<6>usb 2-3: Product: 802.11 bg WLAN
<6>usb 2-3: Manufacturer: Ralink
<6>usbcore: registered new interface driver rt73usb

In der Netzwerkkonfiguration unter Yast wurde auch ein Netzwerk
eingetragen, und unter Hardware erscheint "Modulname: rt73usb", was ja
korrekt wàre.

Das Network-Manager-log spuckt folgendes aus:

wlan0: Device is fully-supported using driver 'rt73usb'.
wlan0: driver supports SSID scans (scan_capa 0x01).
Found new wireless (802.11) device 'wlan0'.
(wlan0): exported as /org/freedesktop/Hal/devices/net_00_17_9a_0a_db_de_0
(wlan0): device state change: 1 -> 2
(wlan0): bringing up device.
<WARN> nm_device_hw_bring_up(): (wlan0): device not up after timeout!
(wlan0): deactivating device.
(wlan0): device state change: 2 -> 3

Wenn ich den Stick allerdings im laufenden Betrieb einstecke, bekomme
ich folgende Fehlermeldung:

kernel: usb 2-3: new high speed USB device using ehci_hcd and address 4
kernel: usb 2-3: configuration #1 chosen from 1 choice
kernel: phy1: Selected rate control algorithm 'pid'
kernel: usb 2-3: New USB device found, idVendord1, idProduct=3c03
kernel: usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
kernel: usb 2-3: Product: 802.11 bg WLAN
kernel: usb 2-3: Manufacturer: Ralink
ifup: interface 'wmaster0' is a wlan helper interface. Exiting.
ifup: Network interface is managed from NetworkManager
ifup: NetworkManager will be advised to set up wlan0
ifup: but it cannot be assured from here.
firmware.sh[4105]: Cannot find firmware file 'rt73.bin'
kernel: phy1 -> rt2x00lib_request_firmware: Error - Failed to request
Firmware


Was heißt das denn jetzt? Ist der Treiber/Firmware (rt73usb) vorhanden
oder nicht? Wie kann ich das überprüfen? Wie sollte ich sinnvoll
vorgehen, um das Problem einzugrenzen?

Ich habe gesehen, dass wohl etliche den Stick mit dem Ndiswrapper zum
Laufen gebracht haben, aber ich würde gerne versuchen, es ohne zu schaffen.

Gruß
Daniel
 

Lesen sie die antworten

#1 Juergen Ilse
15/07/2008 - 14:34 | Warnen spam
Hallo,

Daniel Walz wrote:
kernel: usb 2-3: new high speed USB device using ehci_hcd and address 4
kernel: usb 2-3: configuration #1 chosen from 1 choice
kernel: phy1: Selected rate control algorithm 'pid'
kernel: usb 2-3: New USB device found, idVendord1, idProduct=3c03
kernel: usb 2-3: New USB device strings: Mfr=1, Product=2, SerialNumber=0
kernel: usb 2-3: Product: 802.11 bg WLAN
kernel: usb 2-3: Manufacturer: Ralink
ifup: interface 'wmaster0' is a wlan helper interface. Exiting.
ifup: Network interface is managed from NetworkManager
ifup: NetworkManager will be advised to set up wlan0
ifup: but it cannot be assured from here.
firmware.sh[4105]: Cannot find firmware file 'rt73.bin'
kernel: phy1 -> rt2x00lib_request_firmware: Error - Failed to request
Firmware

Was heißt das denn jetzt? Ist der Treiber/Firmware (rt73usb) vorhanden
oder nicht?



"Cannot find firmware file 'rt73.bin'" heisst auf deutsch "kann die Firmware
Datei 'rt73.bin' nicht finden". Diese Datei ist also nicht vorhanden oder
liegt nicht im richtigen Verzeichnis. Wenn du die Datei noch nicht haben
solltest, musst du sie dir von http://www.ralinktech.com/ herunterladen und
in das Firmware-Verzeichnis deiner Distribution tun (welches das ist, wirst
du selbst nachsehen muessen, denn ich habe keine SuSE11.0 hier ...

Wie kann ich das überprüfen?



Ob die Datei vorhanden ist (vermutlich ist sie das nicht) kannst du testen,
indem du in das entsprechende Verzeichnis wechselst und dort "ls rt73.bin"
eintippst ...

Tschuess,
Juergen Ilse ()
Ein Domainname (auch wenn er Teil einer Mailadresse ist) ist nur ein Name,
nicht mehr und nicht weniger ...

Ähnliche fragen