Linux auf Intel D201GLY2A - problematisch?

26/04/2008 - 17:01 von Sebastian Kaps | Report spam
Hi!

Ich habe seit einiger Zeit ein Intel D201GLY2A Board, bestückt mit 1 GB
RAM und einer WLAN-Karte (Atheros) und habe damit mein vorheriges System
auf P3-600-Basis ersetzt.
Die Installation stammt aus dem vorherigen System (bzw. den Systemen).
Seit dem Umbau macht die Kiste nur Probleme uns hàngt sich stàndig mit
einer Kernel Panic auf (wenn der Rechner mal 24h durchlàuft, grenzt das
schon an ein Wunder).
Kernel ist der aktuelle 2.6.25 ohne zusàtzliche Patches, auch ein
testweise installierter 2.6.24.5 zeigt das gleiche Verhalten.

Die Abstürze scheinen unterschiedliche Gründe zu haben. Wenn in den
Logfiles was auftaucht, dann z.B. sowas:

kernel: [ cut here ]--
kernel: kernel BUG at mm/slab.c:602!
kernel: invalid opcode: 0000 [#1]
kernel: Modules linked in: wlan_tkip wlan_scan_sta ath_rate_sample ath_pci wlan ath_hal(P) binfmt_misc nfs tun [last unloaded: mac80211]

oder

kernel: [ cut here ]
kernel: kernel BUG at mm/slab.c:3010!
kernel: invalid opcode: 0000 [#2]

oder

kernel: BUG: unable to handle kernel paging request at 00100104

Oft passiert es auch, daß gar nichts in den Logfiles auftaucht. Der
Rechner hàngt dann einfach und die Scroll-Lock und Caps-Lock LED am
Keyboard blinken. Bei einem dieser Fàlle war noch ein Monitor
angeschlossen. Dort gab es dann zu lesen, daß eine Fatal Exception in
einem Interrupt aufgetreten sei und im Backtrace war was von i8042 zu
lesen. Sehr frustrierend das.

Der Speicher (Kingston Value) scheint okay zu sein. Ich habe ihn zweimal
über 5h mit memtest gequàlt, einmal davon auch in einem anderen Board.
Auch ein testweise eingebautes anderes Speichermodul hat nicht geholfen.
Die CPU ist es auch nicht - bei ein paar Stunden Primzahltest gab es
zumindest auch keine Probleme.

Das einzige, was mir noch als mögliche Ursache einfallen würde ist, daß
sich die SATA-Schnittstelle und die WLAN-Karte einen Interrupt teilen:
,-
| # cat /proc/interrupts
| CPU0
| 0: 76 IO-APIC-edge timer
| 1: 8 IO-APIC-edge i8042
| 8: 116 IO-APIC-edge rtc
| 9: 0 IO-APIC-fasteoi acpi
| 14: 3 IO-APIC-edge pata_sis
| 15: 0 IO-APIC-edge pata_sis
| 17: 494954 IO-APIC-fasteoi sata_sis, wifi0
| 19: 1752842 IO-APIC-fasteoi eth0
| 20: 0 IO-APIC-fasteoi ohci_hcd:usb2
| 21: 1909 IO-APIC-fasteoi ohci_hcd:usb3
| 22: 0 IO-APIC-fasteoi ohci_hcd:usb4
| 23: 2 IO-APIC-fasteoi ehci_hcd:usb1
| NMI: 0 Non-maskable interrupts
| LOC: 550424 Local timer interrupts
| TRM: 0 Thermal event interrupts
| SPU: 0 Spurious interrupts
| ERR: 0
| MIS: 0
`-
Könnte das evtl. für die Probleme verantwortlich sein?
Das Bios bietet leider keine Möglichkeit, den IRQ für den PCI-Slot zu
remappen - kann man das unter Linux irgendwie hinbekommen?

Hat sonst noch jemand dieses Board und Probleme damit (oder auch nicht)?
Irgendwelche Lösungsvorschlàge?

Ciao, Sebastian
 

Lesen sie die antworten

#1 Olaf Kaluza
26/04/2008 - 17:27 | Warnen spam
Sebastian Kaps wrote:


Der Speicher (Kingston Value) scheint okay zu sein. Ich habe ihn zweimal
über 5h mit memtest gequàlt, einmal davon auch in einem anderen Board.



Das Problem ist nur, so wie du es beschreibst sieht es sehr nach einem
defekten Speicher aus. Oder aber ein defektes Motherboard.

Das einzige, was mir noch als mögliche Ursache einfallen würde ist, daß
sich die SATA-Schnittstelle und die WLAN-Karte einen Interrupt teilen:



Ich hatte vor einiger Zeit auch eine Menge Probleme mit einer
SATA-Karte. Die kann dir problemlos deinen Rechner genauso still
setzen wie du es beschreibst, aber es gibt dann einen einen
Zusammenhang mit der Plattennutzung.
Also viel Plattenzugriff gleich viel neu booten. :-)

Olaf

Ähnliche fragen