[linux] Verstaendnisproblem default gateway

20/03/2012 - 15:29 von Lars Uhlmann | Report spam
Gegeben:

eth0: 1.1.1.1/24
eth1: 2.2.2.2/24 (DSL, dynamisch)
default gateway 2.2.2.254 via eth1

Bei einem SSH-Connect auf 1.1.1.1 kommen die Antwortpakete aufgrund des
Default-Gateways über das falsche Interface mit dessen Source-IP zurück,
was logischerweise nicht Nicht-Funktion der Verbindung führt.
Wie kann ich festlegen, daß alles, was an 'eth0' ankommt, den Router auch
wieder über 'eth0' verlàßt?
Sicher làßt sich das über eine Markierung der Pakete und entsprechendem
Routing lösen, aber geht's nciht irgendwie einfacher, eleganter?

Das gleiche Problem besteht ja auch, wenn zwei Interfaces (zwecks
Lastverteilung) im gleichen Subnetz stecken.

Wer kann mich mal erleuchten? ;)

Danke
Lars
 

Lesen sie die antworten

#1 Stefan Dreyer
20/03/2012 - 15:47 | Warnen spam
Am 20.03.2012 15:29, schrieb Lars Uhlmann:
Gegeben:

eth0: 1.1.1.1/24
eth1: 2.2.2.2/24 (DSL, dynamisch)
default gateway 2.2.2.254 via eth1



Das sieht irgendwie merkwürdig aus.

Bei einem SSH-Connect auf 1.1.1.1 kommen die Antwortpakete aufgrund des
Default-Gateways über das falsche Interface mit dessen Source-IP zurück,
was logischerweise nicht Nicht-Funktion der Verbindung führt.



Von welcher IP-Adresse aus versuchst Du denn den SSH-Connect? Hast Du
noch ein weiteres Netz, von dem aus Du den SSH-Connect sendest?


Wie kann ich festlegen, daß alles, was an 'eth0' ankommt, den Router auch
wieder über 'eth0' verlàßt?



Das willst Du gar nicht wirklich, Dein Problem liegt mit Sicherheit
woanders. Pakete aus dem Netz 1.1.1.0/24 gehen auch wieder über eth0
raus. Du musst ein anderes Problem haben.

Sicher làßt sich das über eine Markierung der Pakete und entsprechendem
Routing lösen, aber geht's nciht irgendwie einfacher, eleganter?



Das nennt sich policy-routing, aber das willst Du gar nicht wirklich.

Das gleiche Problem besteht ja auch, wenn zwei Interfaces (zwecks
Lastverteilung) im gleichen Subnetz stecken.



Nein, das Problem besteht da nicht, weil es anders gelöst wird, s.
<http://de.wikipedia.org/wiki/Link_Aggregation>.

Wer kann mich mal erleuchten? ;)



Dazu wàre es hilfreich, wenn Du uns noch mal darlegen würdest, wie Dein
Setup genau aussieht und von welchem Client (IP) aus Du den Connect auf
1.1.1.1 probierst.

Ähnliche fragen