Forums Neueste Beiträge
 

Listen auf Übereinstimmung prüfen...?

23/06/2009 - 07:01 von Harald Haas | Report spam
Hallo zusammen,

haben folgende Aufgabe zu bewàltigen und suchen nach einer
passenden Funktion:

Haben eine Liste in Spalte A eines Arbeitsblattes
eingetragen.
Sagen wir mal, untereinander stehen da so Werte drinne, wie
123-abc, 345-erf, 278-kht,... (mehrere Hundert)
Jetzt haben wir eine zweite Liste von extern in das
Tabellenblatt unserer Mappe reinkopiert (Spalte C).
Wir müssen jetzt prüfen, ob die Werte in der von uns
eingetragenen Liste enthalten sind. Natürlich sollte auch
ausgewiesen werden, dass wenn ein Wert in der externen Liste
nicht enthalten ist.
Konkret geht es darum, dass wir überprüfen müssen, ob etwas
versandtes wieder vollstàndig zurückgekommen ist!

Wir stellen uns dass in etwa so vor, dass Excel die Liste in
Spalte C mit der in Spalte A gegenvergleicht und z. B. in
Spalte B neben jede Zelle ein Ja oder nein, als Ergebnis, ob
der Wert in Spalte C vorhanden ist, eintràgt!

Kann uns hier jemand kurzfristig helfen bzw. einen
Lösungsansatz geben?

Vielen Dank vorab für jede Hilfe und falls noch Fragen offen
sind, ruhig stellen...

Harald
 

Lesen sie die antworten

#1 Thomas Ramel
23/06/2009 - 08:22 | Warnen spam
Grüezi Harald

Harald Haas schrieb am 23.06.2009

Haben eine Liste in Spalte A eines Arbeitsblattes
eingetragen.
Sagen wir mal, untereinander stehen da so Werte drinne, wie
123-abc, 345-erf, 278-kht,... (mehrere Hundert)
Jetzt haben wir eine zweite Liste von extern in das
Tabellenblatt unserer Mappe reinkopiert (Spalte C).
Wir müssen jetzt prüfen, ob die Werte in der von uns
eingetragenen Liste enthalten sind. Natürlich sollte auch
ausgewiesen werden, dass wenn ein Wert in der externen Liste
nicht enthalten ist.

Wir stellen uns dass in etwa so vor, dass Excel die Liste in
Spalte C mit der in Spalte A gegenvergleicht und z. B. in
Spalte B neben jede Zelle ein Ja oder nein, als Ergebnis, ob
der Wert in Spalte C vorhanden ist, eintràgt!

Kann uns hier jemand kurzfristig helfen bzw. einen
Lösungsansatz geben?



Füge in B1 die folgende Formel ein und kopiere sie über einen Dopelklick
auf das Ausfüllkàstchen der Zelle nach unten:

=ZÄHLENWENN(C:C;A1)


Alle Zeilen in Spalte B die eine '0' aufweisen sind in Spalte C nicht
enthalten.

Alle die eine '1' aufweisen sind in Spalte C einmal enthalten.

Alle die einen Wert '>1' aufweisen sind in Spalte C mehrfach enthalten.



Mit freundlichen Grüssen
Thomas Ramel

- MVP für Microsoft-Excel -
[Vista Ultimate SP-1 / xl2007 SP-1]

Ähnliche fragen