Listen vergleichen

25/05/2012 - 08:29 von Thomas | Report spam
Guten Morgen,

ich möchte folgende Aufgabenstellung lösen:

Tabelle 1 enthàlt allgemeine Beschreibungen, Tabelle 2 Prüfwerte. Nun
ist nicht jedes Element aus Tabelle 1 in Tabelle 2 enthalten. Wie kann
ich herausbekommen welches Element aus Tabelle 1 in Tabelle 2 enthalten
ist? Als Ordnungsmerkmal steht in beiden Tabellen in Spalte A eine
eindeutige Bezeichung.

Hàndisch die Spalten A in beiden Tabellen zu vergleichen wird schwierig
... in Tabelle 1 befinden sich 12000 Datensàtze, in Tabelle 2 3500
Datensàtze.

Kann mir _ohne_ VBA geholfen werden?

Vieen Dank für die Mühe.

Mit freundlichem Gruß
Thomas
 

Lesen sie die antworten

#1 Peter Schuerer
25/05/2012 - 16:00 | Warnen spam
Am 25.05.2012 08:29, schrieb Thomas:
Guten Morgen,

ich möchte folgende Aufgabenstellung lösen:

Tabelle 1 enthàlt allgemeine Beschreibungen, Tabelle 2 Prüfwerte. Nun
ist nicht jedes Element aus Tabelle 1 in Tabelle 2 enthalten. Wie kann
ich herausbekommen welches Element aus Tabelle 1 in Tabelle 2 enthalten
ist? Als Ordnungsmerkmal steht in beiden Tabellen in Spalte A eine
eindeutige Bezeichung.

Hàndisch die Spalten A in beiden Tabellen zu vergleichen wird schwierig
... in Tabelle 1 befinden sich 12000 Datensàtze, in Tabelle 2 3500
Datensàtze.

Kann mir _ohne_ VBA geholfen werden?

Vieen Dank für die Mühe.

Mit freundlichem Gruß
Thomas



Hallo Thomas,

erstelle in Tabelle 1 eine Hilfsspalte mit der Formel,

=ZÄHLENWENN(Tabelle2!$A$2:$A$30;A2)

und kopiere die Formel nach unten.
Markiere den gesamten Datenbereich in Tabelle 1 (außer die Hilfsspalte).
Klick auf "Format" und "Bedingte Formatierung...". Bei Bedingung 1
"Formel ist" auswàhlen und die Formel

=WENN(B2=1;1)

eingeben, eine Farbe (helles Grau) auswàhlen und fertig.
Jetzt werden alle Datensàtze in Tabelle 1, die auch in Tabelle 2
vorhanden sind, grau markiert.

MfG
Peter

Ähnliche fragen