Listview fuellen - Laufzeitfehler

04/01/2010 - 11:28 von Volker Neurath | Report spam
Hallo zusammen,

und erstmal ein frohes neues Jahr euch allen - besonders den fleissigen
und geduldigen Helfern hier.

Ich habe derzeit folgendes Problem:
ich möchte auf einem Formular ein ListView einsetzen. Leider làsst sich
das nicht füllen, beim öffnen des Formulars kommt sofort ein
Laufzeitfehler

"sie haben einen Ausdruck erstellt, der einen unzulàssigen Verweis auf
die Eigenschaft | enthàlt"

angemeckert wird im Debugger die zweite Zeile im WITH block

Hier der Code:
-
Option Compare Database
Option Explicit

Private mListView As MSComctlLib.ListView

Property Get objListView() As MSComctlLib.ListView
If mListView Is Nothing Then
Set mListView = Me!lvwDistributoren.Object
End If
Set objListView = mListView
End Property

Private Sub Form_Load()
Dim objListItem As ListItem
Dim db As DAO.Database
Dim rs As DAO.Recordset

Set db = CurrentDb
Set rs = db.OpenRecordset("tblDirectCustomer", dbOpenSnapshot)

'Listview füllen

Do While Not rs.EOF
Set objListItem = objListView.ListItems.Add(, "a" & rs!SapNr,
rs!SapNr)
With objListItem
.ListSubItems.Add , , rs!strDirectName
.ListSubItems.Add , , rs!Country <-- wird markiert
End With
rs.MoveNext
Loop

rs.Close
Set rs = Nothing
Set db = Nothing
End Sub


Hat jemand eine Idee, woran das liegen könnte?

Volker

Wenn es vom Himmel Zitronen regnet -- lerne, Limonade zu machen.
 

Lesen sie die antworten

#1 Mark Doerbandt
04/01/2010 - 11:58 | Warnen spam
Hallo, Volker,

Volker Neurath:

Ich habe derzeit folgendes Problem:



warum machst Du einen neuen Thread auf?

Hast Du WithEvents denn wenigstens mal probiert?

Gruss - Mark

Informationen fuer Neulinge in den Access-Newsgroups unter
http://www.doerbandt.de/Access/Newbie.htm

Bitte keine eMails auf Newsgroup-Beitràge senden.

Ähnliche fragen