Loginskript in Loopbackpolicy funktioniert nicht

08/04/2010 - 17:19 von Marc Borst | Report spam
Hallo NG,

ich habe einen Windows 2008R2 Terminal Server. Ich möchte für die Benutzer,
die sich dort anmelden ein Loginskript ausführen, welches einen Registry Key
in HKCU setzt. Das Skript arbeitet bei manueller Ausführung einwandfrei. Das
Skript wird in einer Loopbackpolicy als Logon Skript eingetragen, jedoch
niemals ausgeführt. Führe ich als Benutzer einen gpresult /V aus, bekomme ich
die Policy als "übernommen" angezeigt, allerdings folgenden Hinweis für die
Benutzerrichtlinie:

Anmeldeskripts
Gruppenrichtlinienobjekt: xxx_Policy
Name: login.bat
Parameter:
Zuletzt ausgeführt: Dieses Skript wurde noch nicht ausgeführt.

Bin für jeden Hinweis dankbar. Gruß,
Marc
 

Lesen sie die antworten

#1 Steffen Seitz
08/04/2010 - 17:35 | Warnen spam
Hi Marc,

ich habe einen Windows 2008R2 Terminal Server. Ich möchte für die Benutzer,
die sich dort anmelden ein Loginskript ausführen, welches einen Registry Key
in HKCU setzt. Das Skript arbeitet bei manueller Ausführung einwandfrei. Das
Skript wird in einer Loopbackpolicy als Logon Skript eingetragen, jedoch
niemals ausgeführt.



..mmh was mit dazu einfàllt ist dies:

Könnte es sein das du die GPO nicht auf eine OU Verknüpft ist in der es auch
User gibt ? Das ist mir schon mal untergekommen das GPO nicht gezogen wurde
da in der verknüpften OU keine User zu finden waren.

Ansonsten als alternative würde mir einfallen den Regkey nicht über script
sondern direkt in der GPO zu setzen, das funktioniert recht zu verlàssig wenn
du nur setzt und nicht irgendwelche auswertungen machen musst um den zu
setzen.

regards
Steffen

Ähnliche fragen