lokale Anmeldung bei aktivem ldap-Client nicht möglich

10/09/2007 - 13:28 von mathias1104 | Report spam
Moin,

ich versuche vergeblich unsere Suse Server dazu zu bewegen eine
Anmeldung als root auch dann zu ermöglichen, wenn der ldap Server down
oder das Netz nicht vorhanden ist.
Derzeit bekomme ich dann immer ein timeout.
Ich möchte, dass zuerst nach lokalen usern und dann nach ldap usern
geschaut wird.

Meine nsswitch.conf auf einem opensuse 10.2:
passwd: files compat
group: files compat
hosts: files dns
networks: files dns
services: files ldap
protocols: files
rpc: files
ethers: files
netmasks: files
netgroup: files ldap
publickey: files
bootparams: files
automount: files nis
aliases: files ldap
passwd_compat: ldap
group_compat: ldap


(Wenn ich in der passwd und group Zeile das compat raus nehme, ist der
client aus.)
Wenn ich "getent passwd" eingebe, sehe ich auch, dass zuerst die
lokalen und dann die ldap user aufgeführt werden.
Wenn ich den Netzwerkstecker ziehe und mich als root anmelde, kommt
nach dem Passwort auch prompt
"Letzte Anmeldung:...", womit die Authentifitierung wohl auch geklappt
haben sollte, aber dass wars dann auch.
Nach 60 Sek. kommt ein Timeout.
Es sieht für mich so aus, als ob er selbst wenn er den User lokal
gefunden hat, die Anmeldung erst beendet, nachdem er auch alle anderen
Quellen durchsuchen konnte.
Wie kann ich das àndern???
passwd_compat: files ldap
group_compat: files ldap
führt dazu, dass ich mich zwar als root einloggen kann und im yast der
ldap client als aktiv gekennzeichnet ist, aber es werden keine ldap
user mehr aufgelöst.
 

Lesen sie die antworten

#1 Benjamin Gufler
10/09/2007 - 13:40 | Warnen spam
Hi.

On 2007-09-10 13:28, mathias1104 wrote:
[...]
Wenn ich "getent passwd" eingebe, sehe ich auch, dass zuerst die
lokalen und dann die ldap user aufgeführt werden.
Wenn ich den Netzwerkstecker ziehe und mich als root anmelde, kommt
nach dem Passwort auch prompt
"Letzte Anmeldung:...", womit die Authentifitierung wohl auch geklappt
haben sollte, aber dass wars dann auch.



Das klingt mir ehrlich gesagt nicht nach einem Problem mit dem
Name-Service-Switch, sondern eher nach einem etwas ungeschickt
konfigurierten PAM. In welcher Reihenfolge stehen denn LDAP und lokale
Files dort beim Sitzungsaufbau?

Benjamin

Ähnliche fragen