Lösungsansätze für Netzwerk XP-Rechner zu Vista-Rechner

05/10/2008 - 14:20 von Harald Maedl | Report spam
Ich hatte Netzwerkprobleme bei einem Netzwerk mit einem Rechner mit XP
Prof SP3 und einem Rechner mit Vista Business SP1. Letztgenannter ist
ein Laptop, der über WLan und Router ins Netzwerk eingebaut werden
sollte.
Am XP-Rechner hàngen noch weitere Rechner mit OS XP Prof SP3 und das
Netzwerk mit diesen Rechnern funktioniert, zumindest konnte ich bis
jetzt keine Probleme feststellen.

Der XP-Rechner konnte nun zwar auf den Vista-Rechner zugreifen, aber
umgekehrt funktionierte es nicht - Meldung: "keine Berechtigung". Die
Meldung in der IPConfig waren unverdàchtig und gaben keinen Anlass, dass
die Verbindung nicht hàtte aufgebaut werden können.

Nun kamen im Netz folgende Tipps, die ich am XP-Rechner ausgeführt
hatte, btw ohne Erfolg. Da mittlerweile das Netzwerk làuft (die Lösung
meines Problems folgt am Schluss), möchte ich gerne wissen, was ich da
eingestellt habe und ob ich gegebenenfalls diese Einstellungen wieder
rückgàngig machen sollte.

1."regedit"
"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa" den Eintrag
"RestrictAnonymous" (Typ REG_DWORD) und setzen Sie den Wert auf "0".

[Frage: Was bewirkt dieser Eintrag]

2. Systemsteuerung/Verwaltung/Lokale Sicherheitseinstellungen:
Unter "Lokale Richtlinien -> Sicherheitsoptionen" suchen Sie im linkem
Fenster "Netzwerkzugriff: Anonyme Aufzàhlung von SAM-Konten und
Freigaben nicht erlauben" und stellen Sie auf "Deaktiviert".

[Anm. War bereits deaktiviert. Was bewirkt dieser Eintrag?]

Systemsteuerung/Verwaltung/Lokale Sicherheitseinstellungen
Unter "Lokale Richtlinien -> Sicherheitsoptionen" suchen Sie im linkem
Fenster "Konten: Lokale Kontenverwendung von leeren Kennwörtern auf
Kontenanmeldung beschrànken" und stellen Sie auf "Deaktiviert".

[Anm.: War imho bereits deaktiviert, weiß es allerdings nicht mehr
genau]

3. Systemsteuerung/Verwaltung/Dienste"
Im rechten Fenster kontrollieren ob der Dienst "Server" gestartet ist.

[Anm.: war gestartet]

4. Systemsteuerung/Verwaltung/Lokale Sicherheitsrichtlinie"
Unter "Lokale Richtlinien -> Zuweisen von Benutzerrechten" rechts im
Fenster "Zugriff vom Netzwerk auf diesen Computer verweigern" den
Gasteintrag entfernen.

[Anm.: war entfernt]

5. Regedit
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\lanmanserver\parameters"
Eintrag "Hidden" (Typ REG_DWORD) auf Wert "0" setzen

[Anm.: Ein Eintrag Hidden war nicht vorhanden, dennoch angelegt und auf
"0" gesetzt. Kann man den ganz löschen? Was bewirkt dieser Eintrag?]
.
6. Regedit
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters
Den Wert von IRPStackSize um 3 erhöhen
Wenn der Wert IRPStackSize nicht existiert, einen neuen DWord-Wert
namens IRPStackSize erstellen.

[Der Wert war auf 11 --> auf 14 erhöht. Wozu ist das gut?]

7. So nun nochmals schnell einen Ordner freigegeben für die
Benutzergruppe "Jeder"

Gebracht haben alle obigen Punkte nichts, außer dass der Aufruf vom
Netzwerk nun imho tràger vonstatten geht. Aber vielleicht mögen obige
Tipps für die, die àhnliche Probleme haben, nützlich sein.

Nun zur Lösung meines Problems:
Im Computernamen vom XP-Rechner war ein "_" z.B. Haralds_Desktop.
Als ich beim Herumspielen am Vista-Rechner den Computernamen àndern
wollte, ebenfalls dann mit Unterstrich und Vista zu meckern anfing,
klingelte es auf einmal: KEINE Sonderzeichen im Computernamen!
Wobei ich einen Unterstrich nie als Sonderzeichen gesehen habe.
Vista nimmt zwar Bindestriche, aber keine Unterstriche.
Daraufhin habe ich den Computernamen vom XP-Rechner geàndert und den
Unterstrich herausgeworfen.

Der Erfolg war, dass ich nun vom Vista-Rechner auf den XP-Rechner
zugreifen konnte, aber nicht mehr umgekehrt, besser gesagt, nur noch auf
Dateien im Public-Ordner, obgleich ich nichts am Vista-Rechner geàndert
hatte und vorher auf vom XP-Rechner auf einen anderen freigebenen Ordner
zugreifen konnte. Also im Vista-Rechner nochmals die Dateifreigabe
durchgeführt und Rechte für "Jeder" vergeben, die vorher nicht vergeben
waren! Seltsamerweise konnte XP vorher jedoch darauf zugreifen,
irgendwie buggy.

Jedenfalls, jetzt geht es nach vielen Stunden Herumpopelei.
Ich habe gerade zusàtzlich Ubuntu auf den Vista-Rechner gespielt, mal
sehen, wie es mir da ergeht, um ein Netzwerk zu anderen Rechnern
einzurichten. Die Einrichtung des Wlan zum Internet war relativ einfach.
Aber jetzt muss ich den Vista-Loader erstmal dazu bringen, dass er mir
die Ubuntu-Installation nicht zerschießt. Leider benötige ich Vista
noch.
Die anderen Rechner habe ich zwar auf XP Prof downgegradet, aber bei
einem Rechner möchte die Installation erhalten, allein schon, um das
Betriebssystem ein bisschen besser kennenzulernen.
Grüße
Harald
 

Lesen sie die antworten

#1 Stefan Kanthak
06/10/2008 - 06:58 | Warnen spam
"Harald Maedl" schrieb:

Ich hatte Netzwerkprobleme bei einem Netzwerk mit einem Rechner mit XP
Prof SP3 und einem Rechner mit Vista Business SP1. Letztgenannter ist
ein Laptop, der über WLan und Router ins Netzwerk eingebaut werden
sollte.
Am XP-Rechner hàngen noch weitere Rechner mit OS XP Prof SP3 und das
Netzwerk mit diesen Rechnern funktioniert, zumindest konnte ich bis
jetzt keine Probleme feststellen.

Der XP-Rechner konnte nun zwar auf den Vista-Rechner zugreifen, aber
umgekehrt funktionierte es nicht - Meldung: "keine Berechtigung". Die
Meldung in der IPConfig waren unverdàchtig und gaben keinen Anlass, dass
die Verbindung nicht hàtte aufgebaut werden können.

Nun kamen im Netz folgende Tipps, die ich am XP-Rechner ausgeführt
hatte, btw ohne Erfolg. Da mittlerweile das Netzwerk làuft (die Lösung
meines Problems folgt am Schluss), möchte ich gerne wissen, was ich da
eingestellt habe und ob ich gegebenenfalls diese Einstellungen wieder
rückgàngig machen sollte.

1."regedit"
"HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa" den Eintrag
"RestrictAnonymous" (Typ REG_DWORD) und setzen Sie den Wert auf "0".



GANZ bloeder "Tipp". Dieser Wert sollte seit NT4-Zeiten Jahren immer
auf "1" gesetzt sein.

[Frage: Was bewirkt dieser Eintrag]



Ist Dein Google kaputt?
http://support.microsoft.com/kb/143474/en-us
http://support.microsoft.com/kb/246261/en-us
http://technet.microsoft.com/de-de/...18944.aspx

2. Systemsteuerung/Verwaltung/Lokale Sicherheitseinstellungen:
Unter "Lokale Richtlinien -> Sicherheitsoptionen" suchen Sie im linkem
Fenster "Netzwerkzugriff: Anonyme Aufzàhlung von SAM-Konten und
Freigaben nicht erlauben" und stellen Sie auf "Deaktiviert".



Ebenso bloeder "Tipp": wenn Du nicht die "Einfache Dateifreigabe"
(von der DRINGENST abzuraten ist) verwendest, dann aktiviere diese
Einstellung. In der Registry findest Du sie unter
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
"RestrictAnonymousSAM"=dword:01

[Anm. War bereits deaktiviert. Was bewirkt dieser Eintrag?]



S.o: die Suchmaschine Deine geringsten Misstrauens hilft Dir
weiter.
http://www.microsoft.com/technet/se...ch05n.mspx

Systemsteuerung/Verwaltung/Lokale Sicherheitseinstellungen
Unter "Lokale Richtlinien -> Sicherheitsoptionen" suchen Sie im linkem
Fenster "Konten: Lokale Kontenverwendung von leeren Kennwörtern auf
Kontenanmeldung beschrànken" und stellen Sie auf "Deaktiviert".



Wieder ein GANZ bloeder "Tipp"; aktiviere diese Einstellung (es sei
denn, Du willst unbedingt die "Einfache Dateifreigabe" verwenden).

[Anm.: War imho bereits deaktiviert, weiß es allerdings nicht mehr
genau]

3. Systemsteuerung/Verwaltung/Dienste"
Im rechten Fenster kontrollieren ob der Dienst "Server" gestartet ist.

[Anm.: war gestartet]

4. Systemsteuerung/Verwaltung/Lokale Sicherheitsrichtlinie"
Unter "Lokale Richtlinien -> Zuweisen von Benutzerrechten" rechts im
Fenster "Zugriff vom Netzwerk auf diesen Computer verweigern" den
Gasteintrag entfernen.



Noch so ein GANZ bloeder "Tipp"; aktiviere diese Einstellung wieder
(es sei denn, Du willst unbedingt die "Einfache Dateifreigabe"
verwenden)!

[Anm.: war entfernt]

5. Regedit
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\lanmanserver\parameters"
Eintrag "Hidden" (Typ REG_DWORD) auf Wert "0" setzen

[Anm.: Ein Eintrag Hidden war nicht vorhanden, dennoch angelegt und auf
"0" gesetzt. Kann man den ganz löschen? Was bewirkt dieser Eintrag?]



Du solltest lernen, eine Suchmaschine zu bedienen!
http://support.microsoft.com/kb/265284/en-us
http://support.microsoft.com/kb/314498/en-us

6. Regedit
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\LanmanServer\Parameters
Den Wert von IRPStackSize um 3 erhöhen
Wenn der Wert IRPStackSize nicht existiert, einen neuen DWord-Wert
namens IRPStackSize erstellen.

[Der Wert war auf 11 --> auf 14 erhöht. Wozu ist das gut?]



S.o.
Mach zukuenftig Deine Hausaufgaben, BEVOR Du fragst!
http://support.microsoft.com/kb/285089/en-us
http://support.microsoft.com/kb/198386/en-us

7. So nun nochmals schnell einen Ordner freigegeben für die
Benutzergruppe "Jeder"



Solange nicht der in http://support.microsoft.com/kb/278259/en-us
genannte (NICHT empfehlenswerte) Registry-Eintrag

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
"EveryoneIncludesAnonymous"=dword:01

gesetzt ist umfasst die Gruppe "Jeder" nicht "Anonymous".
Zur Vermeidung moeglicher Sicherheitsprobleme sollte statt "Jeder"
besser "Authentifizierte Benutzer" verwendet werden.

Gebracht haben alle obigen Punkte nichts, außer dass der Aufruf vom
Netzwerk nun imho tràger vonstatten geht. Aber vielleicht mögen obige
Tipps für die, die àhnliche Probleme haben, nützlich sein.



Nein, diese Tipps sind wertlos!

Nun zur Lösung meines Problems:
Im Computernamen vom XP-Rechner war ein "_" z.B. Haralds_Desktop.



http://support.microsoft.com/kb/909264/en-us
http://www.microsoft.com/technet/pr..._kdny.mspx
http://technet.microsoft.com/en-us/...78792.aspx

Als ich beim Herumspielen am Vista-Rechner den Computernamen àndern
wollte, ebenfalls dann mit Unterstrich und Vista zu meckern anfing,
klingelte es auf einmal: KEINE Sonderzeichen im Computernamen!



Das empfiehlt der Hersteller Deines Betruebssystems schon seit ueber
12 Jahren!

[...]

Stefan
[
Die unaufgeforderte Zusendung werbender E-Mails verstoesst gegen §823
Abs. 1 sowie §1004 Abs. 1 BGB und begruendet Anspruch auf Unterlassung.
Beschluss des OLG Bamberg vom 12.05.2005 (AZ: 1 U 143/04)

Ähnliche fragen