[LVM] Offset in der VG beim LV einstellen

13/02/2009 - 17:14 von Markus Malkusch | Report spam
Mir ist heute etwas àrgerliches passiert (ist ja auch Fr. der 13.). Ich hab
mein LV gelöscht und wieder erzeugt (anstatt es einfach zu deaktivieren).

Jetzt findet cryptsetup den LUKS-Header nicht mehr. Ich habe per hexedit
einen LUKS-Header bei 0x10000 gefunden und mal das Geràt (es handelt sich
nur um 1 RAID) ohne LVM mittels losetup -o 0x10000 /dev/loop1 /dev/sdb
gequetscht. Immerhin sagt jetzt cryptsetup luksDump /dev/loop1 etwas.
Allerdings ist es nicht das was ich erwartet habe. Da fehlt mind. ein
Schlüssel und ich krieg das Ding nicht entschlüsselt.

Ich hoffe nun, dass cryptsetup einfach mit dem loop Geràt nicht
zurechtkommt. Bevor ich die Daten wegschmeiße, will ich nochmals das LV so
hinbiegen, dass ich diesen LUKS-Header mit dem LV benutzen kann. Das LV
beginnt allerdings weit hinter dem Header so ca. bei 0x31000. Ich habe
bereits das LV mit vgcfgrestore zurück gestellt. Dennoch beginnt das LV so
spàt. Wo kann ich denn einstellen ab wann das LV auf der VG bzw. dem PV
beginnen soll?
Mit PHP Kontonummern auf Gültigkeit prüfen:
<http://bav.malkusch.de/>
 

Lesen sie die antworten

#1 Hauke Laging
14/02/2009 - 02:28 | Warnen spam
Markus Malkusch schrieb am Freitag 13 Februar 2009 17:14:

Ich habe bereits das LV mit vgcfgrestore zurück
gestellt. Dennoch beginnt das LV so spàt. Wo kann ich denn
einstellen ab wann das LV auf der VG bzw. dem PV beginnen soll?



Wie das kommt und Du das beheben könntest, kann ich Dir nicht sagen,
aber vielleicht gibt es eine Alternative, nàmlich dann, wenn Du
mindestens den Platz des wiederherzustellenden LV zusàtzlich zur
Verfügung hast.

1) neues LV erstellen
2) per dd den Inhalt des alten LV ins neue kopieren

Sofern im neuen LV der LUKS-Header und die Daten an der richtigen
Stelle stehen, sollte das doch passen. Oder? :-)


CU

Hauke
http://www.hauke-laging.de/ideen/

Ähnliche fragen