MacGPG von 1 auf 2 umstellen

03/03/2009 - 16:08 von tonne | Report spam
Hallo!

Gestern kam MacGPG 2.0.10 heraus (alte Version war MacGPG 1.4.8):

http://www.macupdate.com/info.php/id/11136/gnupg

Sàmtliche GPG-Tools benutzen aber weiterhin MacGPG 1.4.8, weil der Pfad
ein anderer als zu MacGPG 2.0.10 ist.

In OpenPGP/Enigmail in Thunderbird kann man das in den Preferences
einstellen, indem man den Pfad manuell àndert:

/usr/local/bin/gpg nach /usr/local/bin/gpg2

Alle anderen GPG-Tools, die keine Voreinstellung dafür haben, verwenden
weiter MacGPG 1.4.8 (also /usr/local/bin/gpg).

Nun steht auf der Entwicklerwebsite http://macgpg2.wiki.sourceforge.net/
daß man im Terminal nur einen symbolischen Link zu setzen braucht und
alle anderen GPG-Programm nàhmen dann automatisch MacGPG 2.0.10:

sudo ln -s /usr/local/bin/gpg2 /usr/local/bin/gpg

Habe ich gemacht, nützt aber nichts. Antwort ist:

ln: /usr/local/bin/gpg: File exists

Es wird weiter von den GPG-Tools MacGPG 1.4.8 verwendet, weil der Pfad
offensichtlich nicht angepaßt ist.

Was mache ich nun? MacOSX 10.5.6.

Jörn
 

Lesen sie die antworten

#1 schlu-do
03/03/2009 - 16:16 | Warnen spam
Jörn Eisner schrieb:

Nun steht auf der Entwicklerwebsite http://macgpg2.wiki.sourceforge.net/
daß man im Terminal nur einen symbolischen Link zu setzen braucht und
alle anderen GPG-Programm nàhmen dann automatisch MacGPG 2.0.10:

sudo ln -s /usr/local/bin/gpg2 /usr/local/bin/gpg

Habe ich gemacht, nützt aber nichts. Antwort ist:

ln: /usr/local/bin/gpg: File exists



Klar - dort liegt ja noch die alte Version aus MacGPG 1.4.8 - die
müsstest du erst mal umbenennenoder verschieben.

Es wird weiter von den GPG-Tools MacGPG 1.4.8 verwendet, weil der Pfad
offensichtlich nicht angepaßt ist.



Sind die Versionen denn soweit kompatibel, dass man "einfach so" die
neuere Version statt der alten benutzen kann? Bei einem Versionssprung
von 1.x nach 2.x kann sich ja z.B. am API mal was àndern.

Ansonsten mache vor dem neuen symbolischen Link folgendes:

sudo mv /usr/local/bin/gpg /usr/local/bin/gpg_148

Damit nennst du die alte Version in 'gpg_148' um und das Anlegen des
Links sollte klappen - und wenn doch was nicht geht, kannst du den Link
immer noch löschen und die alte Datei wieder zurückumbenennen.


Gruß,

Dominik.

Ähnliche fragen