Mail - Zeichensatz

17/12/2007 - 10:03 von Robert Medlitsch | Report spam
Hallo,

ich verwende System.Net.Mail.MailMessage für den Versand von Mails. Nachdem
Umlaute nicht korrekt dargestellt wurden, habe ich mal BodyEncoding =
Encoding.Unicode ausprobiert. Was bewirkt hat, dass einige Empfànger das
Mail korrekt dargestellt bekommen, manche allerdings ohne korrekte Umlaute
und wieder andere Empfànger erhalten chinesische oder japanische
Schriftzeichen.

Was muss ich da einstellen, damit der Zeichensatz bei allen Empfàngern OK
ist?


Ciao

Robert Medlitsch
www.MittenImDritten.at
Ein-, Aus-, Rück- und Seitenblicke aus 1030 Wien
 

Lesen sie die antworten

#1 Thomas Bandt
17/12/2007 - 11:25 | Warnen spam
Robert Medlitsch schrieb:
Hallo,

ich verwende System.Net.Mail.MailMessage für den Versand von Mails. Nachdem
Umlaute nicht korrekt dargestellt wurden, habe ich mal BodyEncoding =
Encoding.Unicode ausprobiert. Was bewirkt hat, dass einige Empfànger das
Mail korrekt dargestellt bekommen, manche allerdings ohne korrekte Umlaute
und wieder andere Empfànger erhalten chinesische oder japanische
Schriftzeichen.

Was muss ich da einstellen, damit der Zeichensatz bei allen Empfàngern OK
ist?



Mit Unicode fàhrst du eigentlich richtig - verwende ich
auch. Was für Inhalte verschickst du? HTML, Text? Woher
kommen die? Und mit was für Clients lesen die Empfànger?

Gruß, Thomas [MVP ASP/ASP.NET]
http://www.69grad.de - Beratung, Entwicklung
http://www.dotnetjob.de - .NET-Stellenmarkt
http://blog.thomasbandt.de - Thomas goes .NET

Ähnliche fragen