Mails via Outlook mit OLConnector

23/02/2009 - 16:09 von Thomas Wolf | Report spam
Hallo NG

Ich weiss, das ist nicht direkt eine Access-Frage, aber ich habe den
OLConnector von Sascha Trowitzsch unter
http://www.access-im-unternehmen.de/399.0.html gefunden und kurz getestet.
Funktioniert ja sehr gut.
Benutzt das Tool jemand?
Ich habe drei Fragen dazu:
1. Wenn beim OLConnector im Code das falsche Passwort angegeben ist, dann
kann ich dies nicht abfangen (oder ich weiss zumindest nicht wie) und der
restliche Code fàllt auf die Schnauze. Was kann ich da tun?
2. Das Passwort kann ich bei den Optionen im Mail setzen. Kann ich irgendwie
bei jedem User das gleiche Passwort automatisch einfügen lassen? Oder muss
ich da wirklich bei jedem User von Hand das PW setzen?
3. Die Mails werden nicht im Sent-Ordner abgelegt. Ich gehe davon aus, dass
dies beabsichtigt ist. Kann ich dies trotzdem implementieren?

Gruss
Thomas
 

Lesen sie die antworten

#1 Sascha Trowitzsch
23/02/2009 - 18:09 | Warnen spam
Hi Thomas,

"Thomas Wolf" schrieb im Newsbeitrag
news:
Hallo NG

Ich weiss, das ist nicht direkt eine Access-Frage, aber ich habe den
OLConnector von Sascha Trowitzsch unter
http://www.access-im-unternehmen.de/399.0.html gefunden und kurz getestet.
Funktioniert ja sehr gut.
Benutzt das Tool jemand?
Ich habe drei Fragen dazu:
1. Wenn beim OLConnector im Code das falsche Passwort angegeben ist, dann kann
ich dies nicht abfangen (oder ich weiss zumindest nicht wie) und der restliche
Code fàllt auf die Schnauze. Was kann ich da tun?



Steht doch auf der Seite:
"Ist der Passwort-Modus des OLConnectors eingeschaltet, dann würde im
vorstehenden Code die Objektvariable objOL ungültig sein (Nothing), falls das
übergebene Passwort inkorrekt ist oder die entsprechende Zeile weggelassen
würde."

Also prüfst du objOL auf Nothing. ;-)

2. Das Passwort kann ich bei den Optionen im Mail setzen. Kann ich irgendwie
bei jedem User das gleiche Passwort automatisch einfügen lassen? Oder muss ich
da wirklich bei jedem User von Hand das PW setzen?



Ist aktuell so.
Da das Passwort verschlüsselt abgelegt und ausgelesen wird, gibt es keinen Weg
am Optionen-Dialog vorbei.
Werde das auch nicht mehr àndern. (Es hatte einen Grund, nur fàllt er mir jetzt
leider nicht mehr ein... ;-) )

3. Die Mails werden nicht im Sent-Ordner abgelegt. Ich gehe davon aus, dass
dies beabsichtigt ist. Kann ich dies trotzdem implementieren?



Das hat ja nichts mit dem OLConnector selbst zu tun. Was du mit dem
Application-Objekt schließlich anstellst, das bleibt dir überlassen. Die
Automation làuft identisch ab, wie sonst. Dazu gibt es im Netz ne Menge Code,
der Mailitems als Kopien ablegt, als Entwürfe speichert, direkt versendet, etc.
Es ist halt nur in *meinem Beispielcode* so, dass keine Kopie in Sent entsteht.

Ciao, Sascha

Ähnliche fragen