mailto führt keine Aktion aus

28/12/2008 - 19:48 von Alberto Luca | Report spam
Hallo NewsGroup,

u.s. mailto-href führt leider zu keiner Aktion.
Lediglich ein müdes "Beep" wird entlockt.

Vermutlich liegt es an fehlender / falscher web.config-Einstellung.
u.s. Einstellung ist vermutlich fehlerhaft ("Das deliveryMethod-Attribut
wurde nicht deklariert").

Was ist die Ursache für mein Problem?
Wie müsste das E-Mail-Handling richtig konfiguriert werden?


Coding:
Test,,,(siehe <a href="mailto:hugo@gmx.de">Mail-Adresse</a>).

web.config:
<system.net>
<mailSettings deliveryMethod="Network">
<smtp from="emil@gmx.de">
<network host="mail.gmx.net" port="25" password="xyz"
userName="emil@gmx.de"/>
</smtp>
</mailSettings>
</system.net>

Besten Dank vorab!
Ciao, Alberto
 

Lesen sie die antworten

#1 Stefan Falz [MVP]
28/12/2008 - 20:26 | Warnen spam
Hallo Alberto,

"Alberto Luca" schrieb:

u.s. mailto-href führt leider zu keiner Aktion.
Lediglich ein müdes "Beep" wird entlockt.



mailto: führt auch lediglich dazu, dass ein _auf_dem_Client_
installierter Emailclient aufgerufen und eine Emailvorlage an
erstellt wird.

Vermutlich liegt es an fehlender / falscher web.config-Einstellung.
u.s. Einstellung ist vermutlich fehlerhaft ("Das deliveryMethod-Attribut wurde nicht deklariert").



Willst Du die Email server- oder clientseitig versenden?

Tschau, Stefan
Microsoft MVP - Visual Developer ASP/ASP.NET
http://www.asp-solutions.de/ - Consulting, Development
http://www.aspnetzone.de/ - ASP.NET Zone, die ASP.NET Community

Ähnliche fragen