Makro in Calc will nicht

01/12/2009 - 10:08 von Albrecht Mehl | Report spam
In einem Tabellendokument habe ich ein ganz einfaches Makro erstellt:

1. Nach Eingabe eines Wertes in einer Zelle in die Zelle darunter
gehen, d.h. den gerade eingegebenen Wert annehmen
2. Dokument speichern

Dazu ist das Makro wie üblich aufgenommen und in dem Dokument selbst
gespeichert worden, eine Tastenkombination wurde zugeordnet. Die
Makrosicherheit steht auf hoch; dafür ist dann das persönliche
home-Verzeichnis, in dem das Dokument in einem Unterverzeichnis steht,
als vertrauenswürdig erklàrt worden. Auch in einem anderen
Tabellendokument, in dem das oft benutzte Makro nicht geàndert wurde,
tut es nicht mehr. Es scheint also eine allgemeine Makrosperre vorhanden
zu sein.

Ich bilde mir ein, jetzt nichts anderes als früher gemacht zu haben, und
da ging es klaglos. Für Hinweise auf mögliche Fehler, die ich gemacht
haben könnte, wàre ich dankbar.

openoffice 3.1.1

A. Mehl
Albrecht Mehl |
Schorlemmerstr. 33 |Tel. (06151) 37 39 92
D-64291 Darmstadt, Germany|sehenswert - ungefàhr 'Wir einsam im All'
http://www.phrenopolis.com/perspect...index.html
 

Lesen sie die antworten

#1 Siegfried Höfner
01/12/2009 - 10:37 | Warnen spam
"Albrecht Mehl" schrieb
In einem Tabellendokument habe ich ein ganz einfaches Makro erstellt:



Wie sieht es aus : Code ?

1. Nach Eingabe eines Wertes in einer Zelle in die Zelle darunter
gehen, d.h. den gerade eingegebenen Wert annehmen
2. Dokument speichern

Dazu ist das Makro wie üblich aufgenommen und in dem Dokument selbst
gespeichert worden, eine Tastenkombination wurde zugeordnet. Die



Welche Tastenkombination? Diese Kombination evtl. gelöscht/anders zugeordnet?

Makrosicherheit steht auf hoch; dafür ist dann das persönliche
home-Verzeichnis, in dem das Dokument in einem Unterverzeichnis steht,
als vertrauenswürdig erklàrt worden. Auch in einem anderen
Tabellendokument, in dem das oft benutzte Makro nicht geàndert wurde,
tut es nicht mehr. Es scheint also eine allgemeine Makrosperre vorhanden
zu sein.



Um zu prüfen, ob das Makro überhaupt angesprungen wird : Haltepunkt setzen
(erste echte Befehl nach "Sub" , also nicht auf "rem") und dann ausführen.

Gruß Siegfried

Ähnliche fragen