Makro in einer Funktion benutzen

26/03/2008 - 13:49 von Katshepsut | Report spam
Hallo Leute,
ich möchte mein Makro1 automatisch ausführen lassen, wenn in der Zelle links
daneben ein bestimmter Wert erscheint. Was muß ich tun???
Vorsicht ich bin EXEL-Anfànger!!!
Vielen Dank im voraus

Katrin
 

Lesen sie die antworten

#1 stefan onken
26/03/2008 - 14:20 | Warnen spam
On 26 Mrz., 13:49, Katshepsut
wrote:
Hallo Leute,
ich möchte mein Makro1 automatisch ausführen lassen, wenn in der Zelle links
daneben ein bestimmter Wert erscheint. Was muß ich tun???
Vorsicht ich bin EXEL-Anfànger!!!
Vielen Dank im voraus

Katrin



hallo Katrin,
1. Variante:
vermutlich hast du eine Sub Makro1(). Das musst du im VBA-Editor in
Function Makro1() àndern.
Wenn du zB A1 überwachen willst, ob ein x drin steht, schreibst du in
B1 =WENN(A1="x";Makro1();"")

2. Variante
du kannst alle Änderungen in der Tabelle überwachen. Dazu rechtsklick
auf das Register der Tabelle, dann linksklick Code anzeigen. In das
große Codefenster muss dann
Private Sub Worksheet_Change(ByVal Target As Range)
If Range("A1") = "x" Then Makro1
End Sub

Gruß
stefan

Ähnliche fragen