Makro oder Formel wird nicht ausgeführt

10/09/2008 - 12:39 von Frank Chernjak | Report spam
hallo Excel Gurus.

ich habe eine Tabelle erhalten bei der ein Feld abhàngig von einem Wert über
ein Marko oder Formel geprüft wird.
leider wird nichts ausgeführt bzw. überprüft und es funktioniert nicht. In
A2 steht dann ###. Die Spaltengröße habe ich überprüft. Was könnte das
falsch sein. (Mir ist bewußt das es auch sverweis das gleiche machen würde -
aber da mußte man das ganze Excel umschreiben)


zb.
Tabelle1
in A1 steht A
in A2 steht die Formel =DP(A1)


Tabelle2
DP
=ERGEBNIS(1)
=ARGUMENT("K";2)
Std=0
=WENN(K="A")
Std=5
=ENDE.WENN()
 

Lesen sie die antworten

#1 Lorenz Hölscher
10/09/2008 - 13:02 | Warnen spam
Hallo Frank,

Frank Chernjak schrieb:
zb.
Tabelle1
in A1 steht A
in A2 steht die Formel =DP(A1)


Tabelle2
DP
=ERGEBNIS(1)
=ARGUMENT("K";2)
Std=0
=WENN(K="A")
Std=5
=ENDE.WENN()



das sind ja noch XL4-Makros seligen Angedenkens! Ich kriege bei Deinem
Makro als erstes die Fehlermeldung, dass =RÜCKSPRUNG() fehlt.

Aber unabhàngig davon: wenn Du das in VBA schreibst, mußt Du auch
keine Funktion umschreiben, hast aber viel mehr Möglichkeiten (und
evtl. auch mehr Unterstützung hier, weil XL4-Makros schon seit 10
Jahren tot sind).

tschö, Lorenz

http://www.cls-software.de/cls_soft...elVBA.aspx

Ähnliche fragen