Makro reagiert nicht auf Tastenkombination

06/04/2009 - 15:17 von Thomas Wiedmann | Report spam
Hallo,

einem Makro, das wie die meisten meiner anderen Makros in der Normal.dot im
Projekt NewMacros liegt, habe ich in Word 97 unter
Extras/Anpassen/Befehle/Tastatur (unter der Rubrik Makros) eine
Tastenkombination zugeordnet.
Als Dokumentvorlage war die Normal.dot eingestellt. Die Zuordnung wurde
übernommen, d. h. erscheint auch, wenn ich spàter nochmals unter
Extras/Anpassen/Befehle/Tastatur bei diesem Makro nachsehe. Leider reagiert
das Makro nicht auf diese Tastenkombination - zur Prüfung - auch mal einen
Breakpoint in das Makro gesetzt. Das Makro wird bei dieser Tastenkombination
nicht aufgerufen.

Ergànzend habe ich dieses Makro mal auf die Menüleiste gezogen; beim
Anklicken des Menüs reagiert hier das Makro problemlos.

Weder ist das Makro exotisch (wenige Zeilen, macht ne reine
Schriftformatierung) noch die Tastenkombination - sie war [Alt][Shift] T
Alternativ hab ich's mal mit der Belegung anderer Tastenkombinationen
probiert - geht ebenfalls nicht.
Schließlich hab ich zum weiteren Check diese Tastenkombi einem anderen Makro
zugeordnet - das ging auch.

Alle anderen Makros, denen ich eine Tastenkombi zugeordnet hab, reagieren
darauf.

Hab keine Ahnung, warum's hier nicht geht.

Was könnte die Ursache sein bzw. wie könnte ich ihr auf die Spur kommen?
Wie làßt sich das Problem lösen?


Thomas Wiedmann
 

Lesen sie die antworten

#1 Klaus Linke
12/04/2009 - 21:51 | Warnen spam
bzw. wie könnte ich ihr auf die Spur kommen?



Hallo Thomas,

Wenn du zunàchst die Tastenkombo Strg + Alt + (Num+) verwendest
(Steuerungstaste, Alt-Taste und "+" auf dem Ziffernfeld rechts außen
gleichzeitig), und danach irgendeine Tastenkombination (in Deinem Fall
Alt+Umschalt+T), dann solltest du sehen, ob der Tastenkombination im Moment
ein Makro oder irgendwas anderes zugeordnet ist.

Anpassungen im Dokument und in der verbundenen Dokumentvorlage haben eine
höhere Prioritàt als solche in der Normal.dot -- Vielleicht wurde die
Tastenkombination versehentlich dort etwas zugewiesen? Oder spuckt ein
Add-In in die Suppe?

Gruß,
Klaus

Ähnliche fragen