Matrixformel Anzahl Max-Werte über mehrere Spalten

17/01/2010 - 12:43 von Christian G | Report spam
Hallo,

ich möchte folgendes Problem mit Hilfe einer Formel und dieser NG lösen ;-),
da ich selbst aktuell nicht mehr weiterkomme und nicht weiß, ob das
überhaupt funktioniert.

Aus einer Tabelle N:M mit ganzzahligen Werten möchte ich für jede Zeile N
ermitteln, wie oft ihr Wert pro Spalte das Maximum darstellt.

Soweit bin ich gekommen für eine Tabelle mit :

{=SUMME((B1:R1=MAX(INDIREKT("Z1S"&SPALTE(B1:R1)&":Z19S"&SPALTE(B1:R1);0)))*1)}

Damit bekomme ich aber nur eine 1 in der Zeile, in der der Maximalwert über
alle Werte steht.

Kann mir jemand helfen?

Danke + Gruß


Christian
 

Lesen sie die antworten

#1 Claus Busch
17/01/2010 - 15:18 | Warnen spam
Hallo Christian,

Am Sun, 17 Jan 2010 12:43:37 +0100 schrieb Christian G:

Aus einer Tabelle N:M mit ganzzahligen Werten möchte ich für jede Zeile N
ermitteln, wie oft ihr Wert pro Spalte das Maximum darstellt.

Soweit bin ich gekommen für eine Tabelle mit :

{=SUMME((B1:R1=MAX(INDIREKT("Z1S"&SPALTE(B1:R1)&":Z19S"&SPALTE(B1:R1);0)))*1)}



reicht dir nicht:
=ZÄHLENWENN(B1:R1;MAX(B1:R1)) ?


Mit freundlichen Grüssen
Claus Busch
Win XP PRof SP2 / Vista Ultimate SP2
Office 2003 SP2 /2007 Ultimate SP2

Ähnliche fragen