Matrixfunktion?

20/06/2013 - 12:35 von Holger Marzen | Report spam
Ich bin beim Arbeiten mit Excel 2003 (vorgegeben) auf eine mir
sonderbare Eigenschaft gestoßen. Um die Anzahl der Zellen zu ermitteln,
die das Wort "Monitoring" enthalten, habe ich folgende Formel
eingegeben:

=summe(wenn($a$1:$a$1000 = "Monitoring";1;0))

Allerdings funktioniert diese Formel nur, wenn ich sie nicht mit ENTER
sondern mit STRG-SHIFT-ENTER bestàtige. Sie sei angeblich eine
Matrixfunktion, die mehrere Werte zurückliefern könne.

Nach meinem Verstàndnis ist das falsch, denn eine Summe ist eine
Aggregatfunktion die genau einen Wert zurückliefert.

Kann mir einer die Microsoft-Logik erklàren?
 

Lesen sie die antworten

#1 Claus Busch
20/06/2013 - 12:41 | Warnen spam
Hallo Holger,

Am Thu, 20 Jun 2013 10:35:00 +0000 (UTC) schrieb Holger Marzen:

=summe(wenn($a$1:$a$1000 = "Monitoring";1;0))

Allerdings funktioniert diese Formel nur, wenn ich sie nicht mit ENTER
sondern mit STRG-SHIFT-ENTER bestàtige. Sie sei angeblich eine
Matrixfunktion, die mehrere Werte zurückliefern könne.



das ist falsch ausgedrückt. Es ist eine Matrix-Funktion, weil du durch
die ganze Matrix wandern musst und du soviele Werte bekommst, wie du
Zellen angegeben hast, also 1000. Dort wo Monitoring drin steht gibt es
eine 1, wo nicht eine 0. Und diese 1000 Werte werden addiert und geben
dir die Anzahl Vorkommen von Monitoring zurück.

Warum machst du das nicht einfach über:
=ZÄHLENWENN(A1:A1000;"Monitoring")


Mit freundlichen Grüßen
Claus Busch
Win XP Prof SP3 / Vista Ultimate SP2
Office 2003 SP3 /2007 Ultimate SP3

Ähnliche fragen