Mauscursor bewegt sich in falsche Richtungen

07/09/2007 - 23:19 von Georg Klein | Report spam
Hallo,
ich habe ein Problem mit meiner neu gekauften Maus

input: Kingsis Peripherals Evoluent VerticalMouse 3 as /class/input/input1
input: USB HID v1.10 Mouse [Kingsis Peripherals Evoluent VerticalMouse 3 ]
on u
sb-0000:00:10.2-2


Der Mauscursor geht in falsche Richtungen und zwar:

beim Bewegen nach links geht der Cursor nach schràg linksoben
beim Bewegen nach oben geht der Cursor nach oben
beim Bewegen nach rechts tut sich nichts
beim Bewegen nach unten tut sich nichts

das führt dann dazu, daß der Mauscursor am oberen Bildschirm klebt.

Die Maus funktioniert jedoch nach folgendem Procedere, bei dem 2 Màuse
angeschlossen sind.

- Linux starten
- Linux neu starten
- zuerst die Logitech Maus bewegen
- dann die Evoluent Maus bewegen

Jetzt verhàlt sich der Cursor normal.

Also ein Bug in x.org ist es nicht, da zum Einen die Maus sich auf der
Text-Console per gpm genauso verhàlt und zum Anderen ein upgrade auf eine
neue x-version auch nichts brachte.

Kernel ist

georg@acer:~$ cat /proc/version
Linux version 2.6.18-4-686 (Debian 2.6.18.dfsg.1-12etch2) (dannf@debian.org)
(gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)) #1 SMP Wed May
9 23:03:12 UTC 2007
-

Ein testweises installieren von 2.6.21-2-686 brachte keine Besserung.

Irgendwelche Ideen?

Ich tippe auf einen Bug im Kernel und/oder BIOS.

Georg
 

Lesen sie die antworten

#1 Joern Abatz
08/09/2007 - 03:22 | Warnen spam
On Fri, 07 Sep 2007 23:19:02 +0200, Georg Klein wrote:

Der Mauscursor geht in falsche Richtungen



Das Mausprotokoll ist verkehrt eingestellt oder/und das falsche Device
wird gelesen. Wenn die neue Maus dran ist, liefert /dev/input/mice Events
von ihr?

od -x </dev/input/mice

Kommt da was, wenn man die Maus bewegt?
Wenn ja: gpm einrichten mit -t ps2 -m /dev/input/mice

/etc/X11/xorg.conf kontrollieren:

Section "InputDevice"
...
Driver "mouse"
...

dort Protocol und Device richtig setzen. Ich empfehle auch:

Option "Resolution" "300"

Das ist die Grundgeschwindigkeit der Maus. Ich glaube, die fehlt in Debian.

Jörn

Ähnliche fragen