MAX Wert jeder zweiten Spalte ermitteln

16/12/2008 - 18:17 von Rainer Denzer | Report spam
Hallo NG,

ich brauche Hilfe bei folgendem Problem.

Ich möchte den MAX Wert einer Matrix ermitteln, wobei immer nur jede
zweite Spalte berücksichtigt werden soll.

Beispiel:
Für jeden Tag existieren 2 Spalten mit Werten. D.h. nach 10 Tagen habe
ich 20 Spalten gefüllt. Jetzt möchte ich die Spannweite (MAX-MIN) der
jeweils ersten und zweiten-Tagesspalte berechnen.

Also uche ich den MAX-Wert der 1. Spalte aller Tage und den MAX-Wert der
2.Spalte aller Tage (MIN dann analog).

Mit
{=WENN(REST(SPALTE(D3:BB3);2)=0;SPALTE(D3:BB3);"")
bzw.
{=WENN(REST(SPALTE(D3:BB3);2)=1;SPALTE(D3:BB3);"")}
bekomme ich die Spalte mit dem ersten Wert aber nicht deren Wert selber.

1.) Wie komme ich in dieser Formel an den Zelleninhalt.

2.) Wie kann ich den Bereich in der Formel dynamisch gestalten, damit
ich einfach Spalten hinten anfügen kann? Mit Bereich.Verschieben irgendwie?

Wàre toll, wenn ihr mir weiterhelfen könntet.

Schönen Gruß
Rainer
 

Lesen sie die antworten

#1 Dietmar Vollmeier
16/12/2008 - 18:32 | Warnen spam
Servus Rainer!

*Rainer Denzer* schrieb am 16.12.2008 um 18:17 Uhr...
Also uche ich den MAX-Wert der 1. Spalte aller Tage und den MAX-Wert
der 2.Spalte aller Tage (MIN dann analog).

Mit
{=WENN(REST(SPALTE(D3:BB3);2)=0;SPALTE(D3:BB3);"")
bzw.
{=WENN(REST(SPALTE(D3:BB3);2)=1;SPALTE(D3:BB3);"")}
bekomme ich die Spalte mit dem ersten Wert aber nicht deren Wert
selber.

1.) Wie komme ich in dieser Formel an den Zelleninhalt.



{=MAX((REST(SPALTE(D3:BB3);2)=0)*(D3:BB3))}
{=MAX((REST(SPALTE(D3:BB3);2)=1)*(D3:BB3))}

2.) Wie kann ich den Bereich in der Formel dynamisch gestalten, damit
ich einfach Spalten hinten anfügen kann? Mit Bereich.Verschieben
irgendwie?



Warum dehnst du den Bereich nicht gleich aus auf z.B. IV3

{=MAX((REST(SPALTE(D3:IV3);2)=0)*(D3:IV3))}
{=MAX((REST(SPALTE(D3:IV3);2)=1)*(D3:IV3))}

Wàre toll, wenn ihr mir weiterhelfen könntet.



HTH

und tschüss,
Didi
Alle wollen zurück zur Natur, doch keiner zu Fuß.

Ähnliche fragen