mehrere Abhängigkeiten

19/09/2009 - 11:00 von friedhelm | Report spam
Hallo und guten Tag werte newsgroupler,

ich arbeite mit office 2007 und habe ein Problem mit einer WENN(ODER(UND
bzw. WENN(UND(ODER Funktion:

In einem Formular habe ich fünf Zellen, in denen manuell Werte eingetragen
werden.
Diese fünf Werte sollen in vier Ergebnisfeldern durch Auswertung eine Aktion
- nàmlich ein Kreuz setzen oder eben nicht - auslösen.

Feld A3 kann folgende Werte erhalten: 0, 1, 2 oder 3
Feld A4 kann folgende Werte erhalten: 50, 60, 70, 80, 90 oder 100
Feld A5 hat den Wert 500
Feld A6 wird manuell gefüllt
Feld A7 wird manuell gefüllt

nun die vier Auswertungen:

Feld A8
WENN A6 < A5 DANN "X"
Feld A9
WENN A3 = 3 ODER A4 = 100 UND A7 > 1090 DANN "X"
Feld A10
WENN A3 = 0 oder 1 oder 2 UND A4 <100 UND >P UND A7 > 950 DANN "X"
Feld A11
WENN A8:A10 = leer DANN "X"

Im Moment stehe ich auf dem berühmten Schlauch, denn ich erhalte keine
eindeutige Auswertung, d.h. es darf immer nur eins der Felder A8 bis A11 das
"X" erhalten; bei mir werden derzeit in vielen Fàllen zwei Felder gefüllt.

Werden jeden Tipp dankbar testen und selbstverstàndlich berichten.

Vielen Dank
Friedhelm
 

Lesen sie die antworten

#1 Andreas Killer
19/09/2009 - 11:34 | Warnen spam
friedhelm schrieb:

Im Moment stehe ich auf dem berühmten Schlauch, denn ich erhalte keine
eindeutige Auswertung, d.h. es darf immer nur eins der Felder A8 bis A11 das
"X" erhalten; bei mir werden derzeit in vielen Fàllen zwei Felder gefüllt.


Frag doch einfach die Vorgàngerzellen auf ein "X" ab!?!

Formeln in

A8 =WENN(A6<A5;"X";"")
A9 =WENN(A8<>"X";WENN(UND(ODER(A3=3;A40);A7>1090);"X";"");"")
A10
=WENN(ODER(A8<>"X";A9<>"X");WENN(UND(ODER(A3=0;A3=1;A3=2);A4<100;A4>P;A7>950);"X";"");"")
A11 =WENN(UND(A8:A10<>"X");"X";"")

A11 als Matrixformel eingeben.

Andreas.

Ähnliche fragen