Mehrere Ergebnisse - SVERWEIS+1 (?)

29/06/2010 - 12:48 von Christian Durden | Report spam
Hallo an alle,

wir haben eine Datenbank mit Bestellungen. Jede Bestellung hat eine ID.
Die Datenbank mit den Bestellungen kann ich als CSV in Excel
importieren. Wir haben allerdings das Problem, dass einige Bestellungen
aufgrund interner Besonderheiten in Excel zweimal mit dem selben ID
exportiert werden. Das kommt vor allem dann vor, wenn eine Bestellung
gesplittet wird. Beispiel:

Bestellung 0042 ist in der Datenbank angelegt. Sie beinhaltet zwei
Versendungen. Einmal am 1.4. und am 23.6. Der Excel Import sieht dann
folgendermaßen aus:

Bestellungs ID / Lieferung
0040 / 05.06.2010
0041/ 07.04.20010
0042 / 01.04.2010
0042 / 23.06.2010
0043 / 01.09.2010
Bestellung 0042 kommt also zweimal vor


Frage:
Einige Bestellungen sind sehr speziell und müssen nochmal angefasst
werden. Ohne zu tief ins Detail gehen zu müssen, habe ich folgende Frage:

Wie kann ich auf einem anderen Tabellenblatt, das Tabellenblatt der
importierten Datenbank (Rohdaten) abfragen und mehr als eine Antwort
bekommen?
D.h. wenn ich meine Datenbank nun mit dem SVERWEIS abfragen würde und
ich den ID 0042 als Suchkriterium eingebe, kàme als Antwort nur der
ersten Datensatz raus (da der SVERWEIS den als erstes findet) aber ich
bekommen nicht den zweiten Datensatz, der auch auf 0042 "hört".
Ich möchte also 0042 eingeben und dazu alle Datensàtze bekommen, die in
der Datenbank dazu verhanden sind.

Ich suche also eine Funktion die so àhnlich funktionieren müsste wie
Sverweis+1 (nimm also nicht den 1. Datensatz den Du findest, sondern den
2. Datensatz und das ganze dann für x+1). Oder muss ich das mit einem
Spezialfilter lösen?

Gibt es sowas? Kann ich sowas anders abbilden?



Danke im voraus und viele Grüße

Chris


Server 2003 SP2 & Exchange SP2
MS Office 2000 und 2007 mit allen aktuellen SPs.
 

Lesen sie die antworten

#1 Claus Busch
29/06/2010 - 12:59 | Warnen spam
Hallo Christian,

Am Tue, 29 Jun 2010 12:48:41 +0200 schrieb Christian Durden:

Einige Bestellungen sind sehr speziell und müssen nochmal angefasst
werden. Ohne zu tief ins Detail gehen zu müssen, habe ich folgende Frage:

Wie kann ich auf einem anderen Tabellenblatt, das Tabellenblatt der
importierten Datenbank (Rohdaten) abfragen und mehr als eine Antwort
bekommen?



mach dir doch eine zusàtzliche Spalte für die Anzahl und gebe dann in
der zweiten Zeile ein:
=ZÄHLENWENN($A$2:A2;A2)
Dann kannst du in dieser Spalte nach dem 2. , 3. oder Vorkommen
filtern.


Mit freundlichen Grüssen
Claus Busch
Win XP Prof SP2 / Vista Ultimate SP2
Office 2003 SP2 /2007 Ultimate SP2

Ähnliche fragen