mehrere Wenn-Funktionen

08/09/2008 - 10:13 von wolfgang | Report spam
Hallo NG,
ich habe eine Tabelle mit Monatsnamen. Z.B. Zelle A1 = Januar (bis Zelle A12
= Dezember). In der Zelle B1 kommt, wenn der Monat berechnet worden ist, eine
#.
In einer anderen Zelle (z. B. A15) möchte ich den ersten noch nicht
berechneten Monat anzeigen lassen. D. h. wenn dei Zeile 1 berechnet worden
ist (also eine # in Zelle B1), soll in der Zelle A15 der Februar(A2)
angezeigt werden.das geht so weiter, bis Zelle A12 (Dezember).
Wie kann ich das am besten lösen?

Mfg
Wolfgang
 

Lesen sie die antworten

#1 Dietmar Vollmeier
08/09/2008 - 16:19 | Warnen spam
*wolfgang* schrieb am 08.09.2008 um 10:13 Uhr...
^^^^^^^^
Schàmst du dich für deinen Familiennamen?

ich habe eine Tabelle mit Monatsnamen. Z.B. Zelle A1 = Januar (bis
Zelle A12 = Dezember). In der Zelle B1 kommt, wenn der Monat
berechnet worden ist, eine #.

In einer anderen Zelle (z. B. A15) möchte ich den ersten noch nicht
berechneten Monat anzeigen lassen. D. h. wenn dei Zeile 1 berechnet
worden ist (also eine # in Zelle B1), soll in der Zelle A15 der
Februar(A2) angezeigt werden.das geht so weiter, bis Zelle A12
(Dezember).

Wie kann ich das am besten lösen?



Schreibe/Kopiere in die Zelle A15 folgende Formel
=WENN(MAX((B1:B12="#")*(ZEILE(1:12)));"";INDEX(A1:A12;MAX((B1:B12="#")*(ZEILE(1:12)))+1))

ACHTUNG! Matrix-Formel: Mit [Strg]+[Shift]+[Enter] abschließen.

Wenn bei Dezember (B12) eine # gesetzt wird, wird für A15 eine leere
Zeichenkette übergeben, die Zelle ist also leer.

HTH und tschüss,
Didi
A: Weil es die Lesbarkeit des Textes verschlechtert.
F: Was ist an TOFU so schlimm?
A: TOFU
F: Was ist das größte Ärgernis im Usenet?

Ähnliche fragen