mehrere Werte suchen und in der Reihenfolge in eine Tabelle schreiben

31/07/2013 - 18:13 von peteruhlig | Report spam
Guten Abend Miteinander,

ich habe ein Problem und verzweifle bald.
Es geht um folgendes, ich habe eine lange Tabelle mit Startnummern und Zeiten
Zeiten in Spalte A und die Startnummer in Spalte B
Die Zeiten sind als Tageszeit bis auf eine Tausendstel Sekunde genau angegeben.
Die Startnummern tauchen mehrfach mit unterschiedlichen Zeiten auf.
Ich möchte in einer 2. Tabelle nun nach Startnummern sortiert (Spalte A) die Zeiten in einer Zeile fortlaufend (Spalte B - xxxx )stehen haben.

Hier einfach mal ein Beispiel
Tabelle 1

9:42:03,910 1
9:43:01,280 1
9:43:05,240 2
9:44:01,003 1
9:44:02,220 2
9:44:06,030 3
9:45:00,590 4
9:45:02,087 2
9:45:02,970 3
9:45:21,020 1
9:45:56,850 4
9:46:02,982 3
9:46:20,536 1
9:46:22,180 2
9:46:58,905 4
9:46:59,271 2
9:47:21,950 3
9:47:23,100 3
9:47:39,110 1
9:47:45,100 6
9:48:04,820 1
9:48:17,410 4
9:48:22,929 4
9:48:40,160 2
9:48:43,100 6
9:49:01,190 7
9:49:05,190 2

Tabelle 2 wàre dann für die Startnummer 1
1 9:42:03,910 9:43:01,280 9:44:01,003 9:45:21,020 9:46:20,536 9:47:39,110 9:48:04,820
2 9:43:05,240 9:44:02,220 9:45:02,087 9:46:22,180 9:46:59,271 9:48:40,160 9:49:05,190

Hat jemand eine einfache Idee?
Ich dachte an KKleinste für die ersten Werte und KGrößte für den größten Wert.
geht das?
Bei einer Pivottabelle werden die Kommastellen abgeschnitten.

Viele Grüße
Peter
 

Lesen sie die antworten

#1 Claus Busch
31/07/2013 - 18:40 | Warnen spam
Hallo Peter,

Am Wed, 31 Jul 2013 09:13:49 -0700 (PDT) schrieb :

Tabelle 1

9:42:03,910 1
9:43:01,280 1
9:43:05,240 2
9:44:01,003 1
9:44:02,220 2
9:44:06,030 3
9:45:00,590 4
9:45:02,087 2
9:45:02,970 3
9:45:21,020 1

Tabelle 2 wàre dann für die Startnummer 1
1 9:42:03,910 9:43:01,280 9:44:01,003 9:45:21,020 9:46:20,536 9:47:39,110 9:48:04,820
2 9:43:05,240 9:44:02,220 9:45:02,087 9:46:22,180 9:46:59,271 9:48:40,160 9:49:05,190



liste deine Startnummern in Spalte A in Tabelle2 auf und schreibe dann
in B1:
=WENNFEHLER(INDEX(Tabelle1!$A:$A;KKLEINSTE(WENN(Tabelle1!$B$1:$B$100=$A1;ZEILE($1:$99));SPALTE(A1)));"")
und beende die Eingabe mit STRG+Shift+Enter und ziehe dann nach rechts
und unten bis leere Zellen erscheinen.


Mit freundlichen Grüßen
Claus
Win XP Prof SP3 / Vista Ultimate SP2
Office 2003 SP3 /2007 Ultimate SP3

Ähnliche fragen