Memory leak beim Ausschneiden vieler Dateien?

23/10/2007 - 17:48 von Anonymous | Report spam
Hallo alle!


Ich kenne dieses Problem eigentlich nur von xp32, aber wie es scheint, hat
Vista home premium den selben bug (oder feature).

Ich habe große Bilder-Ordner. Wàhle ich jetzt sagen wir 1000 Dateien aus und
schneide sie aus (ctrl-x), um sie zu verschieben, dann steigt der
Speicherverbrauch um 16%. Bei 600 Dateien sind es etwa 9-10%.
Ich wollte gerade mal (testweise) etwa 4000 Dateien verschieben, jetzt (nach
ctrl+x) ist die Speicherauslastung bei 97%, Vista reagiert sehr tràge, in
ein anderes Verzeichnis einfügen geht nicht. Es passiert rein gar nichts.

explorer.exe: Arbeitsspeichernutzung: privater Arbeitssatz: 1250 MB,
zugesicherte Größe: 1850 MB (handles 360, 6 threads)

Schliessen hilft nix, ich muss explorer.exe crashen.

Genau dasselbe Problem habe ich unter xp32 auch gehabt, bei
unterschiedlichen PCs.
(Vista hp làuft auf einen E6600 mit 2 GB RAM)

Hat jemand eine Lösung oder kann M$ darüber informieren? ;)
Ich glaube kaum, dass ich der einzige mit diesem Problem bin ...


Schöne Grüße!
 

Lesen sie die antworten

#1 Thomas D.
23/10/2007 - 19:08 | Warnen spam
Hallo Robert,

Robert schrieb:

Ich kenne dieses Problem eigentlich nur von xp32, aber wie es scheint, hat
Vista home premium den selben bug (oder feature).

Ich habe große Bilder-Ordner. Wàhle ich jetzt sagen wir 1000 Dateien aus und
schneide sie aus (ctrl-x), um sie zu verschieben, dann steigt der
Speicherverbrauch um 16%. Bei 600 Dateien sind es etwa 9-10%.
Ich wollte gerade mal (testweise) etwa 4000 Dateien verschieben, jetzt (nach
ctrl+x) ist die Speicherauslastung bei 97%, Vista reagiert sehr tràge, in
ein anderes Verzeichnis einfügen geht nicht. Es passiert rein gar nichts.

explorer.exe: Arbeitsspeichernutzung: privater Arbeitssatz: 1250 MB,
zugesicherte Größe: 1850 MB (handles 360, 6 threads)

Schliessen hilft nix, ich muss explorer.exe crashen.



Ich habe das jetzt hier nicht reproduziert, aber wieso bist du der Meinung,
dies sei ein Fehler? Das ist doch u.a. ein Unterschied zwischen kopieren
und ausschneiden (er làdt es in den Speicher, setz das "gelöscht"-Flag
wartet darauf es an den neuen Ort schreiben zu können).

Schließe die Operation einmal ab, anstatt den Explorer vorzeitig zu killen.
Sofern die Auslagerungsdatei noch nicht voll ist, sieht mir alles korrekt
aus, weswegen du auch keine Fehlermeldung bekommst.


Grüße,
Thomas

Ähnliche fragen