Merkwürdigkeiten im Zusammenhang mit Access 2003

05/11/2009 - 18:24 von Thomas Grote | Report spam
Hallo Leute,

nach làngerer Zeit habe ich mal wieder eine ACCESS Anwendung unter ACCESS
2003 entwickelt. Für mich war diese Welt bisher in Ordnung.

Nun aber passieren einige merkwürdige Dinge:

- Access stürzt ab, wenn man z.B. in der Bericht Entwurfsansicht Controls
nur bewegt und den Entwurf anschließend speichert, in einigen Fàllen konnte
der Bericht dann icht mehr geöffnet werden. Nur noch Sicherheitskopien
konnten helfen. Es war ebenfalls kein Import mehr in eine neue DB möglich,
da ich dachte die MDB hàtte evtl. einen Schaden.
- Bestimmte Berichte können nicht mehr vernünftig bearbeitet werden, da die
Rechnerleistung plötzlich extrem absackt, wenn der Bericht in der
Entwurfsansicht geöffnet ist
- Ich bearbeite meine 2003 Anwendung unter Access 2007: Bestimmte VBA bzw.
ADO Funktionen die unter AC2003 einwandfrei laufen, lassen ACCESS 2007
plötzlich komplett mit "Anwendung reagiert nicht mehr" abstürzen (z.B. im
Formular Set Me.Recordset = rs.1 oder if rs1.EOF = True)
- Unter Access 2007 werden in Formularen mit Datenblattansicht nur der erste
Datensatz angezeigt, wenn das Formular als Unterfomular verwendet wird und
es dynamisch an die Datenquelle z.B. mit "me.Recordsource=SQL1" per VBA
gebunden wird. Die SQL Abfrage ergibt eindeutig mehr Datensàtze als einen.
- Auf meinem Notebook mit Office 2003 làßt sich die MDB Datei nicht mehr zu
MDE kompilieren (reparieren ist noch möglich), Access stürzt komplett ab.


Die Anwendung selbst làuft ansonsten ohne Fehler (zumindest unter Access
2003). Die Probleme sind, wie ihr seht, nicht unbedingt hardwareabhàngig.
Und nach fast 15 Jahren ACCESS Erfahrung kommt man nun ins grübeln.
Maßnahmen bisher: Ich habe versucht, Office 2003 neu zu installieren.
Aktuelle Servicepacks wurden installiert.Ich habe das übliche (Reparieren,
MDE Datei erstellen etc.) immer wieder versucht, leider ohne Erfolg.

Weiß jemand Rat ?

Gruß
Thomas
 

Lesen sie die antworten

#1 Henry Habermacher
06/11/2009 - 03:29 | Warnen spam
Hallo Thomas

Thomas Grote wrote:
Die Anwendung selbst làuft ansonsten ohne Fehler (zumindest unter Access
2003). Die Probleme sind, wie ihr seht, nicht unbedingt hardwareabhàngig.
Und nach fast 15 Jahren ACCESS Erfahrung kommt man nun ins grübeln.
Maßnahmen bisher: Ich habe versucht, Office 2003 neu zu installieren.
Aktuelle Servicepacks wurden installiert.Ich habe das übliche (Reparieren,
MDE Datei erstellen etc.) immer wieder versucht, leider ohne Erfolg.



Da fehlen aber noch einige Dinge, die in der FAQ zum Thema Reparatur erwàhnt
sind:
- Decompile
- Objekte in eine neue/leere MDB importieren

Ansonsten könnte es auch der Druckertreiber sein. Stelle mal auf einen
anderen Standard Drucker um und versuche es nochmals.

Gruss
Henry


Microsoft MVP Office Access
Keine E-Mails auf Postings in NGs. Danke.
Access FAQ www.donkarl.com

Ähnliche fragen