Micro-SD Mystery

17/05/2015 - 14:10 von Matthias Böttcher | Report spam
Moin Moin,

im Màrz gab es den Thread "Mini SD formatieren". Daran erinnerte ich
mich, als meine "Transcend 16GB (10) Micro SDHC" nach ca. einem Jahr
Benutzungsdauer anfing zu spinnen. Spinnen heißt:
- einzelne Dateien konnten nicht gelesen werden
- beim Mounten erscheint im syslog: EXT4-fs (sdd2): 2 orphan inodes deleted
- darauf neu gespeicherte oder Änderungen an vorhandenen Dateien waren
nach einem umount und mount verschwunden.

Das ext4 darauf ließ sich nicht mehr reparieren (e2fsck -f /dev/sdd2)
mit der Fehlermeldung:
e2fsck: Superblock-Flags konnten auf /dev/sdd2 nicht gesetzt werden

Formatieren: mkfs.ext4 /dev/sdd2 lief ohne Fehler durch.

Danach mounten, und alles war wie vorher, auch die "alten" Dateien und
Verzeichnisse sind noch vorhanden.

badblocks im Nur-Lesen-Modus über die ganze Karte làuft fehlerfrei
durch, im Lesen+Schreiben-Modus wird jeder Block als defekt erkannt.

Danach ist wieder alles wie vorher.

Letztendlich zeigt sich folgendes Fehlerbild:

Jeder Schreibvorgang des Dateisystems auf die SD-Karte wird als
erfolgreich quittiert, obwohl nichts tatsàchlich geschrieben wurde. So
lange die Karte gemountet ist und die geschriebenen Daten noch im
Kernel Cache sind, sehe ich diese, ansonsten wieder die alten.

Sonnige Grüße
Matthias Böttcher

PS.
Getestet wurde in einem USB-Adapter mit und ohne Adapter von Micro-SD
auf SD an einem Debian-PC und mit dem Micro-SD-auf-SD-Adapter in einem
Debian-Laptop.
(Puh, das war knapp - gerade noch so den Bezug zu Debian hergestellt)


Zum AUSTRAGEN schicken Sie eine Mail an debian-user-german-REQUEST@lists.debian.org
mit dem Subject "unsubscribe". Probleme? Mail an listmaster@lists.debian.org (engl)
Archive: https://lists.debian.org/CAFBm81rYY...aRNUzyJCcg@mail.gmail.com
 

Lesen sie die antworten

#1 Michael Beck
17/05/2015 - 14:30 | Warnen spam
Am 17.05.2015 um 14:01 schrieb Matthias Böttcher :

Moin Moin,

im Màrz gab es den Thread "Mini SD formatieren". Daran erinnerte ich
mich, als meine "Transcend 16GB (10) Micro SDHC" nach ca. einem Jahr
Benutzungsdauer anfing zu spinnen. Spinnen heißt:
- einzelne Dateien konnten nicht gelesen werden
- beim Mounten erscheint im syslog: EXT4-fs (sdd2): 2 orphan inodes deleted
- darauf neu gespeicherte oder Änderungen an vorhandenen Dateien waren
nach einem umount und mount verschwunden.

Das ext4 darauf ließ sich nicht mehr reparieren (e2fsck -f /dev/sdd2)
mit der Fehlermeldung:
e2fsck: Superblock-Flags konnten auf /dev/sdd2 nicht gesetzt werden

Formatieren: mkfs.ext4 /dev/sdd2 lief ohne Fehler durch.

Danach mounten, und alles war wie vorher, auch die "alten" Dateien und
Verzeichnisse sind noch vorhanden.

badblocks im Nur-Lesen-Modus über die ganze Karte làuft fehlerfrei
durch, im Lesen+Schreiben-Modus wird jeder Block als defekt erkannt.

Danach ist wieder alles wie vorher.

Letztendlich zeigt sich folgendes Fehlerbild:

Jeder Schreibvorgang des Dateisystems auf die SD-Karte wird als
erfolgreich quittiert, obwohl nichts tatsàchlich geschrieben wurde. So
lange die Karte gemountet ist und die geschriebenen Daten noch im
Kernel Cache sind, sehe ich diese, ansonsten wieder die alten.

Sonnige Grüße
Matthias Böttcher

PS.
Getestet wurde in einem USB-Adapter mit und ohne Adapter von Micro-SD
auf SD an einem Debian-PC und mit dem Micro-SD-auf-SD-Adapter in einem
Debian-Laptop.
(Puh, das war knapp - gerade noch so den Bezug zu Debian hergestellt)


Zum AUSTRAGEN schicken Sie eine Mail an
mit dem Subject "unsubscribe". Probleme? Mail an (engl)
Archive: https://lists.debian.org/CAFBm81rYYobyoukmwq+



Selber Moun Moin! ;-)

Genau das hatte ich vor ein paar Wochen mit einer (vielleicht gefàlschten?) Sandisk microSDXC (?) 64 GB, die im Samsung-Handy steckte. Es konnte nichts gespeichert werden. Android hatte es aber wenigstens irgendwie mitbekommen und speicherte seitdem alles wieder im internen Speicher.

Am PC:
Schreibvorgànge wie Dateien kopieren, formatieren oder direkt dd wurden alle erfolgreich abgeschlossen, aber beim nàchsten Mount war wieder alles beim Alten. Es war egal, ob ich es unter Debian, Mint, CentOS, Windows XP oder 7, OS X oder Android probiertees war auch egal, welchen Adapter ich verwendete. Es war immer das gleiche. Es ànderte sich nichts.

am Ende habe ich mir eine neue Karte gekauft. Damit funktionierte alles und überall.

Zum AUSTRAGEN schicken Sie eine Mail an
mit dem Subject "unsubscribe". Probleme? Mail an (engl)
Archive: https://lists.debian.org/

Ähnliche fragen