Forums Neueste Beiträge
 

Microsoft .NET Framework Service Pack 2 Sicherheitsupdate

07/06/2010 - 15:08 von Adam Loch | Report spam
Hallo NG,

automatisches Update des Microsoft .NET Framework Service Pack 2
Sicherheitsupdate für Windowss 2000, Windows Sever 2003 und XP (KB974417)
funktioniert nicht.

Ein paar Minuten nachdem die Update-Installation durchgeführt wurde -
Meldung "Installation abgeschlossen." - , taucht das Symbol "Neue Updates
sind verfügbar" , das zwischenzeitlich mal weg war, wieder auf.

Eine Wiederholung der Installation führt zum gleichen Ergebnis.

Was kann ich tun, damit die Installation sauber angeschlossen wird?

Benötigt man denn .NET Framework 2.0 noch, wenn .NET Framework 3.5
installiert ist?

MfG
 

Lesen sie die antworten

#1 Hermann
07/06/2010 - 15:38 | Warnen spam
Adam Loch schrieb:
Ein paar Minuten nachdem die Update-Installation durchgeführt wurde -
Meldung "Installation abgeschlossen." - , taucht das Symbol "Neue
Updates sind verfügbar" , das zwischenzeitlich mal weg war, wieder auf.



Führe eine Reparatur von Framework durch. Systemsteuerung,
Software. Klick auf "Ändern".

Starte in den abgesicherten Modus.

Den Ordner "SoftwareDistribution" im Ordner Windows löschen.
Windows, System32 Den Ordner CatRoot 2 löschen. Nicht den
Ordner CatRoot.

Leere die Temp-Ordner.

Start/Ausführen: temp
Start/Ausführen: %temp%

Neustart.

Weitere Möglichkeit: Downloade folgendes Tool.

http://support.microsoft.com/kb/976220/

Auf C:\ abspeichern. Start/Ausführen: cmd
Wechsele nach C:\ (Mit: cd /d c:\)

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Curr entVersion\Installer\
UserData\S-1-5-18\Products

Suche Framework unter Products. (InstallProperties) Im rechten Fenster
steht eine Zahlenkolonne.
Z. B.: MsiExec.exe /I{CE2CDI62-0124-45CA-87L3-9F3DCF5C5BD8}

In der Eingabeaufforderung (cmd) nun:

PatchRegCleanup-x86.exe {CE2CDD62-0124-36CA-84D3-9F4DCF5C5BD9}
Mache das bei allen Framework-Eintràgen. Schau, ob es nun geht.

Sollte es dann immer noch nicht funktionieren, alle Versionen
deinstallieren und anschließend von der Update-Seite neu in-
stallieren.

http://www.update.microsoft.com/microsoftupdate

Benötigt man denn .NET Framework 2.0 noch, wenn .NET Framework 3.5
installiert ist?



Ja. Gehört zu 3.5

Gruß

Hermann

Ähnliche fragen