"Mit eingeschraenktem Zugriff verbunden", Vista SP1.

08/05/2009 - 15:43 von Rainer Wahl | Report spam
Ich habe mit meinem Notebook ein Problem und weiß nicht so recht, ob
das Problem jetzt mein Router verursacht, oder Vista.

An meinem Router hàngen 2 PCs (mit XP) via LAN und gelegentlich das
Notebook (mit Vista) via WLAN. Bei den PCs gibt es nie Probleme. Das
Notebook hingegen kann sich manchmal nicht mit dem Router verbinden und
Vista meldet ""mit eingeschrànktem zugriff verbunden". Dann hilft nur
den Router Aus- und wieder Einschalten. Danach verbindet sich das
Notebook wieder mit dem Router und man kann auf das Internet zugreifen.

DHCP ist im Router aktiviert und wie gesagt klappt ja via LAN auch
alles.

Ich vermute, daß der Router dem Notebook eine IP vergibt, sowie er ich
soz. das erste mal meldet. Danach erst wieder, wenn die IP automatisch
verfàllt. Vista scheint sich diese zugewiesene IP nicht zu merken und
fliegt das nàchste mal auf die Nase, da der Router die IP nicht wieder
sendet und Vista dann "ohne zugewiesene IP da steht". (Wobei dann die
Frage ist, wieso die gleiche Sache via LAN einwandfrei funktioniert.)

Im Router kann ich nichts groß dazu konfigurieren, was mich weiter
bringen würde. Der hier ist es übrigens:
http://www.alternate.de/html/produc...werk_WLAN-
Router/Linksys/WAG160N/274317/?tn=HARDWARE&l1=Netzwerk&l2=Router

In Vista auf dem Notebook bin ich auch schon alles durch soweit und
weiß nicht mehr, woran ich noch drehen sollte. Feste IPs möchte ich
ungern vergeben, vor allem weil es grundsàtzlich ja funktioniert. Nur
Vista zickt herum via WLAN.

Hat da jemand einen Tipp?


-=( Rainer )=-

Airbrush FAQ: http://www.r-wahl.de/airbrush/faq.php
Baubericht ME-109 RC-Flugmodell:
http://www.r-wahl.de/modellbau/me-109/me-109.php
 

Lesen sie die antworten

#1 Lars P. Wolschner
08/05/2009 - 17:25 | Warnen spam
Rainer Wahl :

Ich habe mit meinem Notebook ein Problem und weiß nicht so
recht, ob das Problem jetzt mein Router verursacht, oder Vista.

An meinem Router hàngen 2 PCs (mit XP) via LAN und gelegentlich
das Notebook (mit Vista) via WLAN. Bei den PCs gibt es nie
Probleme. Das Notebook hingegen kann sich manchmal nicht mit dem
Router verbinden und Vista meldet ""mit eingeschrànktem zugriff
verbunden". Dann hilft nur den Router Aus- und wieder
Einschalten. Danach verbindet sich das Notebook wieder mit dem
Router und man kann auf das Internet zugreifen.

DHCP ist im Router aktiviert und wie gesagt klappt ja via LAN
auch alles.

Ich vermute, daß der Router dem Notebook eine IP vergibt, sowie
er ich soz. das erste mal meldet. Danach erst wieder, wenn die
IP automatisch verfàllt.



Nein, die Clients - die beiden Desktop-PCs und das Notebook -
senden einen DHCP-Request, sobald ihr Betriebssystem gestartet ist
bzw. die Netzwerkverbindung aufgebaut werden soll. Im Falle des LAN
geschieht das, sobald die Ethernetleitung eingesteckt wird. Beim
WLAN geschieht das jedesmal nach Aufbau der physikalischen Funkver-
bindung, also auch nachdem diese im laufenden Betrieb unterbrochen
wurde.

Vista scheint sich diese zugewiesene IP nicht zu merken und
fliegt das nàchste mal auf die Nase, da der Router die IP nicht
wieder sendet und Vista dann "ohne zugewiesene IP da steht".
(Wobei dann die Frage ist, wieso die gleiche Sache via LAN
einwandfrei funktioniert.)



Bei schwacher Funkverbindung klappt oft schon diese DHCP-Kommuni-
kation nicht, so daß unter Windows XP "das Kügelchen ewig rollt"
(sofern man "Symbol bei Verbindung im Infobereich anzeigen"
aktiviert hat), bis aufgegeben und "eingeschrànkte Konnektivitàt"
gemeldet wird. Nur in seltenen Fàllen hilft es dann, manuell eine
geeignete IP-Adresse zuzuweisen; wenn DHCP schon nicht geht, hat
man i.d.R. auch mit allem anderen Probleme.

Ansonsten könntest Du ja mal versuchen, mit einer "alternativen IP-
Konfiguration" zu arbeiten. Das ist eine IP-Konfiguration, die in
solchen Fàllen verwendet werden soll und gab es schon unter Windows
XP. Hier solltest Du allerdings eine IP-Adressen einstellen, die
zwar im Subnetz Deines LANs liegt, aber nicht vom DHCP-Server ver-
geben wird.

Hauptsàchliche Abhilfe dürfte aber darin bestehen, die Empfangs-
probleme Deines WLAN zu lösen, falls nicht die Firmware Deines
Routers fehlerhaft ist und auf den neuesten Stand gebracht werden
muß.

Mit freundlichen Grüßen
Lars P. Wolschner

Ähnliche fragen