Mit Funktion "FINDEN" Felder von rechts nach links durchsuchen?

27/02/2008 - 14:20 von Sebastian | Report spam
Hallo zusammen!

Gibt es eine Möglichkeit Excel dazu zu bringen, die Formel FINDEN von
rechts nach links anzuwenden beim Durchsuchen von Feldern? Wenn man
bei Optionen/International das betreffende Feld ankreuzt, dann
passiert nichts.
Die Formel:
=WENN(ANZAHL(FINDEN("(";H638));TEIL(H638;FINDEN("(";H638)+1;FINDEN(")";H638)-
FINDEN("(";H638)-1);"")
durchsucht momentan Felder nach Klammern und greift deren Inhalt ab.
Es gibt aber Felder, in denen mehr als eine Klammer vorkommt und dann
soll immer die jeweils rechte Klammer ausgelesen werden.
Danke und Gruß

Sebastian
 

Lesen sie die antworten

#1 Christian Kaiser
27/02/2008 - 14:59 | Warnen spam
Hallo Sebastian

die Formel kommt mir bekannt vor :)
kommt auch das + mehrfach vor?
wenn nicht würde ich einach das + abfragen
und nicht die Klammer

ansonsten wird halt die Formel ein klein wenig lànger

=WENN(ANZAHL(FINDEN("(";A1));TEIL(A1;FINDEN("|";WECHSELN(A1;"(";"|";LÄNGE(A1)-LÄNGE(WECHSELN(A1;"(";""))))+1;FINDEN("|";WECHSELN(A1;")";"|";LÄNGE(A1)-LÄNGE(WECHSELN(A1;")";""))))-FINDEN("|";WECHSELN(A1;"(";"|";LÄNGE(A1)-LÄNGE(WECHSELN(A1;"(";""))))-1);"")
Feedback nicht vergessen
Gruß Chris



"Sebastian" wrote:

Hallo zusammen!

Gibt es eine Möglichkeit Excel dazu zu bringen, die Formel FINDEN von
rechts nach links anzuwenden beim Durchsuchen von Feldern? Wenn man
bei Optionen/International das betreffende Feld ankreuzt, dann
passiert nichts.
Die Formel:
=WENN(ANZAHL(FINDEN("(";H638));TEIL(H638;FINDEN("(";H638)+1;FINDEN(")";H638)-
FINDEN("(";H638)-1);"")
durchsucht momentan Felder nach Klammern und greift deren Inhalt ab.
Es gibt aber Felder, in denen mehr als eine Klammer vorkommt und dann
soll immer die jeweils rechte Klammer ausgelesen werden.
Danke und Gruß

Sebastian

Ähnliche fragen