Mit openSuse 11.0 kann ich grub nicht so installieren, dass ich windows starten kann

03/10/2008 - 18:13 von Jochen Bach | Report spam
Hallo NG,

zur Zeit habe ich auf meinem Rechner Ubuntu 8.04, OpenSuse 11.0,
WindowsXP und Windows Vista installiert. Die Betriebssysteme starte ich
derzeit mit grub aus der Ubuntu-Installation die auch wunderbar
funktioniert. Die Windows-Versionen werden dabei über das Windows Vista
Bootmenu gestartet, der über grub aufgerufen wird.

Nun möchte ich mich aber von Ubuntu trennen und versuche über grub aus
der openSuse-Installation zu starten.

Meine Konfiguration soweit für grub notwendig:

menu.lst unter Grub (funktioniert)

splashimage=(hd0,6)/erde/downloads/83234-splash.xpm.gz
default 5
timeout 5

title Ubuntu 8.04, kernel 2.6.24-19-generic
root (hd0,8)
kernel /boot/vmlinuz-2.6.24-19-generic
root=UUID=c33ac071-9269-43db-a7ec-ba1b7232f72d ro vgay1
initrd /boot/initrd.img-2.6.24-19-generic
quiet

title Ubuntu 8.04, kernel 2.6.24-19-generic (recovery mode)
root (hd0,8)
kernel /boot/vmlinuz-2.6.24-19-generic
root=UUID=c33ac071-9269-43db-a7ec-ba1b7232f72d ro single
initrd /boot/initrd.img-2.6.24-19-generic

title Anderes Linux System:
root

title openSUSE 11.0 - 2.6.25.16-0.1
root (hd1,4)
kernel /boot/vmlinuz-2.6.25.16-0.1-pae
root=/dev/disk/by-id/scsi-SATA_SAMSUNG_SP2504CS09QJ1GLB13213-part5
resume=/dev/sdb7 vgay1
initrd /boot/initrd-2.6.25.16-0.1-pae

title Anderes Betriebssystems:
root

title Windows Vista/Longhorn (loader)
root (hd0,0)
chainloader +1
savedefault
makeactive

menu.lst OpenSuse 11 (funktioniert nicht)

gfxmenu (hd1,4)/boot/message
default 0
timeout 8

title openSUSE 11.0 - 2.6.25.16-0.1
root (hd1,4)
kernel /boot/vmlinuz-2.6.25.16-0.1-pae
root=/dev/disk/by-id/scsi-SATA_SAMSUNG_SP2504CS09QJ1GLB13213-part5
resume=/dev/sdb7 splash=silent showopts vga=0x317
initrd /boot/initrd-2.6.25.16-0.1-pae

title Failsafe -- openSUSE 11.0 - 2.6.25.16-0.1
root (hd1,4)
kernel /boot/vmlinuz-2.6.25.16-0.1-pae
root=/dev/disk/by-id/scsi-SATA_SAMSUNG_SP2504CS09QJ1GLB13213-part5
showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0
edd=off x11failsafe vga=0x317
initrd /boot/initrd-2.6.25.16-0.1-pae

###Don't change this comment - YaST2 identifier: Original name: windows###
title windows
rootnoverify (hd0,0)
chainloader (hd0,0)+1 (chainloader +1 habe ich auch erfolglos
probiert)
savedefault
makeaktive

linux-ll64:/home/jochen # fdisk -l

Platte /dev/sda: 500.1 GByte, 500107862016 Byte
255 Köpfe, 63 Sektoren/Spuren, 60801 Zylinder
Einheiten = Zylinder von 16065 × 512 = 8225280 Bytes
Disk identifier: 0x6522a440

Geràt boot. Anfang Ende Blöcke Id System
/dev/sda1 * 1 14912 119779616 7 HPFS/NTFS
/dev/sda2 14913 60801 368603392+ f W95 Erw. (LBA)
/dev/sda5 25498 47030 172963791 7 HPFS/NTFS
/dev/sda6 47031 60801 110615526 7 HPFS/NTFS

Ubuntu 8.04
/dev/sda7 18815 25497 53681166 83 Linux

/dev/sda8 14913 15532 4980087 82 Linux Swap / Solaris
/dev/sda9 15533 18814 26362633+ 83 Linux

Partitionstabelleneintràge sind nicht in Platten-Reihenfolge

Platte /dev/sdb: 250.0 GByte, 250059350016 Byte
16 Köpfe, 63 Sektoren/Spuren, 484521 Zylinder
Einheiten = Zylinder von 1008 × 512 = 516096 Bytes
Disk identifier: 0x1f66803f

Geràt boot. Anfang Ende Blöcke Id System
/dev/sdb1 * 1 304762 153600016+ 7 HPFS/NTFS
/dev/sdb2 304763 484521 90598536 f W95 Erw. (LBA)

openSuse 11.0

/dev/sdb5 304763 346370 20970274+ 83 Linux
/dev/sdb6 346370 474364 64508976 83 Linux
/dev/sdb7 474364 484516 5116671 82 Linux Swap / Solaris

device.map

(hd0) /dev/sda
(hd1) /dev/sdb

Mit der Datei menu.lst aus openSuse 11.0 kann ich openSuse problemlos
starten. Windows zu starten gelingt nicht. Ich erhalte dort den Fehler
17 .. File not found.. angezeigt.

Wer kann mir helfen? Was habe ich falsch gemacht?

cu
Jochen
openSuse 11.0, Linux 2.6.25.16-0.1-pae SMP i686,
KDE 3.5.10 "release 27.1"
Intel(R) Core(TM)2 Quad CPU Q6600, GeForce 8800 GT, 4 GB DDR2 RAM
 

Lesen sie die antworten

#1 Uwe Premer
03/10/2008 - 18:42 | Warnen spam
Am Fri, 03 Oct 2008 18:13:17 +0200 schrieb Jochen Bach:

Hallo NG,



Hallo Jochen,

zur Zeit habe ich auf meinem Rechner Ubuntu 8.04, OpenSuse 11.0,
WindowsXP und Windows Vista installiert.


[...]

Ich hab eine àhnliche Konfiguration:
2x Windows XP Pro,
Ubuntu 8.0.4.1,
openSUSE 11.0 64-Bit

Meine Konfiguration soweit für grub notwendig:

[...]
menu.lst OpenSuse 11 (funktioniert nicht)

[...]
###Don't change this comment - YaST2 identifier: Original name:
###windows###
title windows
rootnoverify (hd0,0)
chainloader (hd0,0)+1 (chainloader +1 habe ich auch erfolglos
probiert)
savedefault
makeaktive


[...]

Wer kann mir helfen? Was habe ich falsch gemacht?



Die Abschnitte bei mir lauten:

###Don't change this comment - YaST2 identifier: Original name: windows
###2###
title windows 2
rootnoverify (hd0,9)
chainloader (hd0,2)+1

###Don't change this comment - YaST2 identifier: Original name: windows
###1###
title windows 1
rootnoverify (hd0,9)
chainloader (hd0,0)+1


CU, Uwe

Ähnliche fragen