Mittelwert mit Monat=1 funktioniert nicht

20/02/2008 - 20:36 von Enterich | Report spam
Hallo,
ich habe ein Problem mit der Funktion "Mittelwert".
Ausgangsposition folgende Tabelle:
A B C

Datum
24. Jan. 32,21 1,429
31. Jan. 41,23 1,399
10. Feb. 33,89 1,259
04. Apr. 29,21 1,399
30. Apr. 40,57 1,429
5. Mai 48,39 1,299
13. Mai 42,22 1,359
28. Mai 53,12 1,399
usw.

In Spalte F(F3-F15) soll die Summe der Spalte B eines jeden Monats.
Habe ich gelöst mit:
{=SUMME(WENN(MONAT($A$3:$A$15)=1;$F$3:$F$15))}
{=SUMME(WENN(MONAT($A$3:$A$15)=2;$F$3:$F$15))} usw für andere Monate
Funktioniert.

In Spalte G(G3-G15) soll der Mittelwert der Spalte C eines jeden
Monats.
Wollte ich lösen mit:
{=MITTELWERT(WENN(MONAT($A$3:$A$15)=1;$E$3:$E$15))} usw für andere
Monate
Funktioniert nicht richtig.
Das Problem:
Monat Januar ergibt falschen Wert (leere Felder werden mit berechnet.
Diese Felder sind wirklich leer, keine Null oder Formeln)
Monate mit Daten ergeben korrekten Wert.
Monate ohne Wert (z.B. Màrz) ergeben #DIV/0!

Hat jemand eine Idee, wo mein Fehler liegt?

Danke und Gruß

Jörg
 

Lesen sie die antworten

#1 Alexander Wolff
20/02/2008 - 21:31 | Warnen spam
Versuchs mal so (ich habe C:C und E:E evtl. nicht richtig verstanden):

=SUMMENPRODUKT((MONAT(A3:A15)=1)*ISTZAHL(C3:C15)*E3:E15)/(
(SUMMENPRODUKT((MONAT(A3:A15)=1)*ISTZAHL(C3:C15))=0)/1%%%%
+SUMMENPRODUKT((MONAT(A3:A15)=1)*ISTZAHL(C3:C15)))

Nach Belieben bitte runden! (empfohlen!)
Moin+Gruss Alexander - MVP for MS Excel - www.xxcl.de - mso2000sp3 --7-2

Ähnliche fragen