Mobile Client -> normale Webseite -> falscher Content-Type Header

23/01/2008 - 16:54 von Christoph Unfried | Report spam
Ich habe folgendes Problem:

Bei Anfrage auf unsere ASP.NET Applikation von einem Handy aus (konkret
Nokia Broswer) erhalte ich im Response als HTTP-Header 'Content-Type'
folgendes:
- text/vnd.wap.wml; charset=utf8

Die Seite an sich ist allerdings XHTML 1.0!!

Wie kommt IIS auf diesen Content-Type? Beim Aufruf von einem PC aus ist
alles korrekt!

Ich brauche hier so schnell wie möglich eine Lösung. D.h. wie kann den IIS
so konfigurieren, dass er immer text/xhtml... schickt?

Die Umgebung:
- IIS 6 auf Windows 2003 Server SP2
- ASP.NET 2.0

Besten Dank für die Hilfe.

Christoph
 

Lesen sie die antworten

#1 Christoph Unfried
24/01/2008 - 10:21 | Warnen spam
Ich habe die Ursache entdeckt:
http://msdn2.microsoft.com/en-us/li...2ssx2.aspx

:)

Lg

Christoph

"Christoph Unfried" wrote:

Ich habe folgendes Problem:

Bei Anfrage auf unsere ASP.NET Applikation von einem Handy aus (konkret
Nokia Broswer) erhalte ich im Response als HTTP-Header 'Content-Type'
folgendes:
- text/vnd.wap.wml; charset=utf8

Die Seite an sich ist allerdings XHTML 1.0!!

Wie kommt IIS auf diesen Content-Type? Beim Aufruf von einem PC aus ist
alles korrekt!

Ich brauche hier so schnell wie möglich eine Lösung. D.h. wie kann den IIS
so konfigurieren, dass er immer text/xhtml... schickt?

Die Umgebung:
- IIS 6 auf Windows 2003 Server SP2
- ASP.NET 2.0

Besten Dank für die Hilfe.

Christoph

Ähnliche fragen