Modem sendet nicht

23/04/2008 - 22:57 von Sascha Manns | Report spam
Servus,

ich habe hier OpenSuse 10.3 mit dem neuesten Hylafax (4.4.0-22).
Folgende Umgebung: Thomson VoIP-Modem (KabelDeutschland); 2xRJ11 Anschlüsse,
mit jeweils 2 Adapter (RJ11 auf TAE-NFN),
ein normales Modem (Pragmatic 56k) auf ttyS0
normales Internet über Ethernet an VoIP-Modem.

Modem an ttyS0 angeschlossen. TAE an Adapter, Beide Leitungen können von
einem analogen Telefon benutzt werden uns sind frei. Beide können auch über
zwei getretnnte Nummern erreicht werfden. Die Telefonanlage (VoIP Modem)
sendet das Freizeichen.

Auf OS 10.3 habe ich das Paket hylafax geladen und anschliessend faxsetup
und addmodem ausgeführt. Danach habe ich die /etc/inttab editiert, und den
Teil mit faxgetty auskommentiert, und auf /dev/ttyS0 gesetzt.

Anschliessend integrierte ich es in OOo via spadmin. Zuletzt schrieb ich
hylafax in die /etc/init.d/boot.local. Und fuhr die Kiste wieder hoch.
Im verbose Modus des Bootloaders konnte ich auch keien Fehlermeldungen
bemerken. Somit ging ich nach OOo und verfasste ein Testfax, dass ich an
einen Freund senden wolte. OOo übergab das Dokument auch brav an das
faxgetty, und das Modem schaltete mit einem Klicken von zwei auf drei
L#mpchen. Ganz kurze Zeit darauf klickte es aber wieder, so dass er den
Verbindungsversuch abbtach.

Also schmiss ich minicom -s an. Die Befehle ATZ und ATDTxxxxxxxxxxxx werden
akzepriert. Das Modem klackt wieder und meldet "NO DIALTONE". Also habe ich
es mit ATX3 versucht, und das klappte ein bisschen. Zumindest dauert der
Verbindungsaufbau lànger. Wenn ich diesen Verbindungsaufbau mit Return
beende kommt "NO CARRIER".
Interessanterweise hat das Modem aber nach dem W#hlen der Nummer (mein
Telefon auf der anderen Leitung) getutet, als wenn es làuten würde. Aber
auf meinem Telefon kam mein Klingeln, auch nach dem Abheben hat sich das
Fax nixht gemeldet.

So wie ich das sehe scheint hylafax ordentlich zu funktionieren, und einzig
bei der Übermittlung zum Modem und von dort weiter scheint es Probleme zu
geben.

Mir fàllt aber nix mehr ein, habe auch die HowTo s und das Wiki
durchgesehen, bin aber mit meinem Latein am Ende...

Weiß jemand Rat?
 

Lesen sie die antworten

#1 Holger Petersen
24/04/2008 - 09:19 | Warnen spam
Sascha Manns writes:

Servus,



Moin!

ich habe hier OpenSuse 10.3 mit dem neuesten Hylafax (4.4.0-22).



Was hat 'hylafax' was 'mgetty&sendfax' nicht hat?

Folgende Umgebung: Thomson VoIP-Modem (KabelDeutschland); 2xRJ11 Anschlà¼sse,
mit jeweils 2 Adapter (RJ11 auf TAE-NFN),



Ob *das* funktioniert (Fax via Voice over IP) ist fraglich...

ein normales Modem (Pragmatic 56k) auf ttyS0



Hast Du eventuell weitere Test-Geraete?

Auf OS 10.3 habe ich das Paket hylafax geladen und anschliessend faxsetup
und addmodem ausgefà¼hrt.



Also gleich mit "Kanonen" gestartet...


Danach habe ich die /etc/inttab editiert, und den
Teil mit faxgetty auskommentiert, und auf /dev/ttyS0 gesetzt.


^^^
Du meinst sicherlich: Das Kommentar-Zeichen entfernt...

Anschliessend integrierte ich es in OOo via spadmin. Zuletzt schrieb ich
hylafax in die /etc/init.d/boot.local. Und fuhr die Kiste wieder hoch.
Im verbose Modus des Bootloaders konnte ich auch keien Fehlermeldungen
bemerken. Somit ging ich nach OOo und verfasste ein Testfax, dass ich an
einen Freund senden wolte.



Und dann sofort die "Zimmerflak" genommen...


Also schmiss ich minicom -s an.



Das haetti ich als erstes gemacht. Wenn es damit nicht geht, sind wohl
alle weiteren Programme auch problematisch.


Die Befehle ATZ und ATDTxxxxxxxxxxxx werden
akzepriert.



Gut.

Das Modem klackt wieder und meldet "NO DIALTONE".



Das kann es nur wenn Du ein Ziel anwaehlst. Hast Du aber
nicht geschrieben...


Also habe ich
es mit ATX3 versucht, und das klappte ein bisschen. Zumindest dauert der
Verbindungsaufbau là¤nger. Wenn ich diesen Verbindungsaufbau mit Return
beende kommt "NO CARRIER".



Das waere normal - WENN die Gegenstelle nicht antwortet.
Alternativ auf einen Timeout warten...

Interessanterweise hat das Modem aber nach dem W#hlen der Nummer (mein
Telefon auf der anderen Leitung) getutet, als wenn es là¤uten wà¼rde. Aber
auf meinem Telefon kam mein Klingeln, auch nach dem Abheben hat sich das
Fax nixht gemeldet.



Du hast also Dein eigenes Telefon angewaehlt?
Da sollte zwar eigentlich 'klingeln'; aber wenn Du nicht so pfeiffen
kannst wie "Ilse Werner" dann wirst Du schwerlich einen CONNECT be-
kommen...


So wie ich das sehe scheint hylafax ordentlich zu funktionieren,



Mag sein - oder auch nicht.


und einzig
bei der àœbermittlung zum Modem und von dort weiter scheint es Probleme zu
geben.



Hmmm...

-=-
Was passiert, wenn Du mit gestartetem 'minicom' per Telefon das Modem
anwaehlst? Es sollte der text " Ring " erscheinen.

Was passiert, wenn Du per 'minicom' das Modem dazu bringst, ein externes
Telefon bei einem vorab informierten Bekanntem (bzw. Dein Handy) anwaehlst?

Was passiert, wenn Du per minicom ein definiert funktionsfaehiges
Modem *extern* anwaehlst[*]?

Fragend, Holger

[*] Eine solche Nummer zu bekommen ist aber schwierig. Unter Umstaenden
funktioniert ein Fax-Geraet. Ich wuesste zwar eine; aber Deine Mail-
Adresse erweckt mir wenig Vertrauen...

Ähnliche fragen