modprobe acpi geht nicht

20/02/2008 - 09:24 von Anton Blau | Report spam
Hallo Newsgroup,

nach einem Mainboardwechsel habe ich unter

cat /proc/acpi/thermal_zone

keine Eintràge mehr.

Ein lsmod | grep acpi

bringt keinen Eintrag.

Deshalb vermute ich, dass es am fehlenden acpi-Modul liegt.

Ein modprobe acpi scheitert mit der Fehlermeldung:

gustav:~# modprobe acpi
FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.18/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko):
Device or resource busy

cpufreq-info geht:

gustav:~# cpufreq-info
cpufrequtils 002: cpufreq-info (C) Dominik Brodowski 2004-2006
Bitte melden Sie Fehler an linux@brodo.de.
analysiere CPU 0:
Treiber: nforce2
Folgende CPUs können nur gleichzeitig ihre Frequenz variieren: 0
Hardwarebedingte Grenzen der Taktfrequenz: 1.29 GHz - 1.84 GHz
mögliche Regler: userspace, ondemand, conservative, powersave,
performance
momentane Taktik: die Frequenz soll innerhalb 1.29 GHz und 1.84 GHz.
liegen. Der Regler "powersave" kann frei entscheiden,
welche Taktfrequenz innerhalb dieser Grenze
verwendet wird.
momentane Taktfrequenz ist 1.29 GHz (verifiziert durch Nachfrage bei
der Hardware).


Wie kann ich denn das Modul acpi laden?


Danke!
 

Lesen sie die antworten

#1 Thomas Ogrisegg
20/02/2008 - 13:09 | Warnen spam
Anton Blau wrote on 2008-02-20:
[...]
Ein lsmod | grep acpi

bringt keinen Eintrag.



Weil der "Treiber" fuer die Temperatursensoren "thermal" heisst und
kein acpi im Namen traegt. Probier mal 'modprobe thermal'.

Ein modprobe acpi scheitert mit der Fehlermeldung:



Es gibt, wenn mich jetzt nicht alles taeuscht, kein acpi-Modul. D.h. ein
'modprobe acpi' versucht dann mittels matching acpi-cpufreq zu laden,
was logischerweise scheitern muss, wenn bereits andere cpufreq-Module
geladen sind.

Ähnliche fragen