MOSFET Gate schwingt beim Ausschalten

21/11/2010 - 12:50 von Johannes Bauer | Report spam
Hallo Gruppe,

ich habe hier einen kleinen Testaufbau, mit dem ich mit MOSFETs
rumexperimenteire. Momentan habe ich einen IRF9540 P-FET in der
Schaltung, Source an etwa +15V. Gate mit 1k Pullup an Source wird von
einem BC547 auf GND gezogen, um ihn anzuschalten.

Am Drain hàngt eine LC-Kombination (15mH, 470uF) um die Ausgangsspanung
zu glàtten.

Jetzt sehe ich folgendes Phànomen: Beim Ausschalten des FET sehe ich
heftige Überschwinger. Siehe
http://s3.directupload.net/file/d/2...9v_png.htm

Ich habe schon probiert, den Gate/Source-Pullup zu verkleinern, um ihn
schneller zum Ausschalten zu bringen, das hat aber nichts gebracht. Und
ich hatte auch eine SB130 zwischen Gate und Source geklemmt, um die
Spannungsspitzen kurzzuschließen, aber das hatte seltsamerweise auch so
gut wie keinen Effekt (zu schnell für die Diode?). Einfügen eines
Widerstands am Gate (Experiment 47, 470, 1k) ànderte auch nichts. Auch
ein Einfügen eines R zwischen Drain und meinem Sieb/Glàttglied (1 Ohm,
10 Ohm) hat das nicht geàndert.

Ich bin jetzt schon ziemlich verweifelt, und kann mir das nicht so recht
klàren. Ich nehme an ich hab mir irgendwo einen schönen Schwingkreis
gebaut. Wie kann ich das verhindert? Was muss ich àndern?

Viele Grüße,
Johannes



Wo hattest Du das Beben nochmal GENAU vorhergesagt?


Zumindest nicht öffentlich!


Ah, der neueste und bis heute genialste Streich unsere großen
Kosmologen: Die Geheim-Vorhersage.
- Karl Kaos über Rüdiger Thomas in dsa <hidbv3$om2$1@speranza.aioe.org>
 

Lesen sie die antworten

#1 MaWin
21/11/2010 - 13:18 | Warnen spam
"Johannes Bauer" schrieb im Newsbeitrag
news:

ich habe hier einen kleinen Testaufbau, mit dem ich mit MOSFETs
rumexperimenteire. Momentan habe ich einen IRF9540 P-FET in der
Schaltung, Source an etwa +15V. Gate mit 1k Pullup an Source wird von
einem BC547 auf GND gezogen, um ihn anzuschalten.

Am Drain hàngt eine LC-Kombination (15mH, 470uF) um die Ausgangsspanung
zu glàtten.

Jetzt sehe ich folgendes Phànomen: Beim Ausschalten des FET sehe ich
heftige Überschwinger. Siehe
http://s3.directupload.net/file/d/2...9v_png.htm

Ich habe schon probiert, den Gate/Source-Pullup zu verkleinern, um ihn
schneller zum Ausschalten zu bringen, das hat aber nichts gebracht. Und
ich hatte auch eine SB130 zwischen Gate und Source geklemmt, um die
Spannungsspitzen kurzzuschließen, aber das hatte seltsamerweise auch so
gut wie keinen Effekt (zu schnell für die Diode?). Einfügen eines
Widerstands am Gate (Experiment 47, 470, 1k) ànderte auch nichts. Auch
ein Einfügen eines R zwischen Drain und meinem Sieb/Glàttglied (1 Ohm,
10 Ohm) hat das nicht geàndert.

Ich bin jetzt schon ziemlich verweifelt, und kann mir das nicht so recht
klàren. Ich nehme an ich hab mir irgendwo einen schönen Schwingkreis
gebaut. Wie kann ich das verhindert? Was muss ich àndern?




Dein "Ausschalten" erfolgt ganz weich über 1k.
Klarer Fall von selber schuld,
Was denkst du warum andere Leute MOSFET-Treiber mit
wenigen Ohm und mehr Bauteilen aufbauen, z.B. so:

++-- +Ub
R4 |
+--|< NPN
| |E
| +-- Gate
| |E
+--|< PNP
Pin --R1-+--|< |
R2 |E |
+++- GND


Aus Spass? Aus Dummheit?

Sicher nicht. Eine steigende bzw. fallende Spannung am Drain
führt natürlich zu Rückkopplungen auf das Gate, schon alleine
weil Drain und Gate nah beieinander und demnach also auch
kapazitiv gekoppelt sind und die Spannungen gegenlàufig sind.
Man versucht also den MOSFET durch Verringern von Ugs auszuschalten,
dabei steigt Uds und es koppelt kapazitiv in Ugs rein. Ist Ugs dabei
eher schalff angebunden, führt das zu einer Spannungserhöhung und dem
Widereinschalten bzw. zumindest nicht so schnellen Ausschalten wie
man es gerne haben will.

Allerdings sind deine 8V am Ausgang eher konstant.

Gerde eine geschaltete Spule, wenn diese auch noch ohne Freilaufdiode
ist, führt aber zu massiven Spannungsànderungen "Prinzip Zündfunke"
die zwar vielleicht die Ursache sind, aber in deinen Oszillogrammen
nicht erkennbar sind. Deine SB130 sollte vielleicht eher zwischen Drain
und GND. Schau dir mal die Schaltung eines StepDown an, wo da die
Diode sitzt, die notwendig ist.

Man kann einen Strom durch eine Spule nicht schnell abschalten.
Der Strom sucht sich seinen Weg. Warum auch immer in deinen
Diagrammen davon nichts zu sehen ist.
Manfred Winterhoff, reply-to invalid, use mawin at gmx dot net
homepage: http://freenet-homepage.de/mawin/
de.sci.electronics FAQ: http://dse-faq.elektronik-kompendium.de/
Read 'Art of Electronics' Horowitz/Hill before you ask.
Lese 'Hohe Schule der Elektronik 1+2' bevor du fragst.

Ähnliche fragen