Mount Problem?

06/05/2009 - 20:17 von Mike Lederer | Report spam
Hallo Leute,

habe hier ein wahrscheinlich kleines Problem was mich aber zur Verzweiflung
bringt :-(
Ich habe eine USB-HDD die ich an einem vorgegebenen Mount-Point als User
einbinden möchte und dies ist mir nach sehr langem herum probieren bis
heute noch nicht gelungen. Die USB-HDD wird immer automatisch beim
anstoepseln mit root rechten eingebunden und ich haenge sie als SU mit
umount immer aus und haenge sie dann als User wieder ein was ja
logischerweise sehr laestig ist.
Folgende Eintraege in der fstab habe ich versucht und sehr vieles in der 4.
Spalte aber nichts funktionierte (Der Mount-Point /media/extern existiert)
und die Volumenbezeichnung ist "extern".

/dev/scd1 /media/extern ext3 users,autoacl,user_xattr 0 0

/dev/extern /media/extern ext3 noauto,users,autoacl,user_xattr 0 0

Mit diesen Eintraegen wird die USB-HDD unter /media/extern-1 eingehaengt was
ja auch nicht in meinem Sinne ist und ohne Eintrag wird sie
unter /media/usb0 eingehaengt.
Bein versuch die USB-HDD auszuhaengen bekomme ich folgende Meldung:
Das Lösen der Geràteeinbindung ist aufgrund des folgenden Fehlers
fehlgeschlagen:
Device to unmount is not in /media/.hal-mtab so it is not mounted by HAL.

Wo ist mein Denkfehler oder was mache ich da nur falsch?
Warum steht die USB-HDD nicht in der mtab wen ich Eintraege in der fstab
habe und sie mounte?
Nachlesen im Kofler hilft mir leider auch nicht sehr viel oder ich verstehe
es hier leider nicht.

Wer kann mir fast am Boden zerstoerten User helfen?

Die besten Gruesse
Mike

PS: Falls interessant, System: Debian Lenny
Vergessene Konfiguration? Steht alles als X-Tags im Header!
 

Lesen sie die antworten

#1 Hauke Laging
07/05/2009 - 00:06 | Warnen spam
Mike Lederer schrieb am Mittwoch 06 Mai 2009 20:17:

haenge sie als SU mit umount immer aus und haenge sie dann als User
wieder ein was ja logischerweise sehr laestig ist.

/dev/extern /media/extern ext3 noauto,users,autoacl,user_xattr 0 0



Was ist autoacl?


Insgesamt finde ich Deine Darstellung etwas verwirrend. Das mag auch
der Grund dafür sein, dass bisher keiner geantwortet hat...


Mit diesen Eintraegen wird die USB-HDD unter /media/extern-1
eingehaengt was ja auch nicht in meinem Sinne ist und ohne Eintrag
wird sie unter /media/usb0 eingehaengt.



Das heißt, wenn Du "mount" eingibst, siehst Du sie
unter /media/extern-1 bzw. /media/usb0?


Bein versuch die USB-HDD auszuhaengen bekomme ich folgende Meldung:
Das Lösen der Geràteeinbindung ist aufgrund des folgenden Fehlers
fehlgeschlagen:
Device to unmount is not in /media/.hal-mtab so it is not mounted
by HAL.



Du meinst, wenn Du als root "umount /media/extern-1" eingibst? Das
wàre schon arg komisch, weil - nach meinem Verstàndnis - mount
nichts mit HAL zu tun hat, sondern HAL auch nur mount aufruft.


Warum steht die USB-HDD nicht in der mtab wen ich Eintraege in der
fstab habe und sie mounte?



Du mountest sie erfolgreich? Woran siehst Du das? Kein Eintrag in
mtab, aber in /proc/mounts?


Hauke
http://www.hauke-laging.de/ideen/

Ähnliche fragen