.MoveFirst funktioniert nicht

24/01/2008 - 09:53 von Jan | Report spam
Hi Leute,

hab seid gestern noch ein Problem.

Mit dem Befehl
"If tabellejetdb.RecordCount > 0 And Not tabellejetdb.EOF Then
tabellejetdb.MoveFirst"

möchte ich erzwingen, dass das Programm an die erste Stelle/Zeile der
Datenbank geht (Datenbank ist zu diesem Zeitpunkt auch korrekt geöffnet).
Jedoch beginnt er immer mit Zeile 8 und dessen werten.

Es funktioniert auch nicht, wenn ich nur den ".MoveFirst" Befehl gebe.

Hat jemand ein Tipp für mich woran das liegen könnte? Verzweifel langsam ein
wenig.

Hintergrund: Mein Makro erfordert desöfteren das durchgehen einer Tabelle.
Daher muss dieser befehl auch ein paar mal genutzt werden.

Besten Dank im vorraus!!!
 

Lesen sie die antworten

#1 Jan
24/01/2008 - 15:47 | Warnen spam
Mhm, hat keiner eine Idee? Schade...

"Jan" wrote:

Hi Leute,

hab seid gestern noch ein Problem.

Mit dem Befehl
"If tabellejetdb.RecordCount > 0 And Not tabellejetdb.EOF Then
tabellejetdb.MoveFirst"

möchte ich erzwingen, dass das Programm an die erste Stelle/Zeile der
Datenbank geht (Datenbank ist zu diesem Zeitpunkt auch korrekt geöffnet).
Jedoch beginnt er immer mit Zeile 8 und dessen werten.

Es funktioniert auch nicht, wenn ich nur den ".MoveFirst" Befehl gebe.

Hat jemand ein Tipp für mich woran das liegen könnte? Verzweifel langsam ein
wenig.

Hintergrund: Mein Makro erfordert desöfteren das durchgehen einer Tabelle.
Daher muss dieser befehl auch ein paar mal genutzt werden.

Besten Dank im vorraus!!!

Ähnliche fragen