mpd macht Mucken

26/03/2009 - 21:28 von Jakobus Schürz | Report spam
Hallo Gemeinde.

Wieder einmal macht mein mpd nicht das was er soll.

Erstens ist mir aufgefallen, dass der mpd immer gleich 3 Instanzen
startet. "ps auxf" zeigt diese drei Instanzen als Mutter, Kind und
Enkel. Alle Drei zeigen "/usr/bin/mpd /etc/mpd.conf"
Warum reicht da nicht eine einzige?

Ok, ich weiß nicht, ob das die Ursache für mein Problem ist.
Wenn ich Musik höre, dann klingt die dumpf und ab und zu hört es sich
an, als ob ein Altes Radio in ein laaanges Kanalrohr gestellt würde.
Echoeffekte und Soundeffekte wie eben die Wiedergabe in einem langen
Rohr. Anders kann ich das nicht treffender beschreiben.

Manchmal tritt das auf, wenn ich ein Frontend start und hört auf, wenn
ich das Frontend schließe, manchmal tritt es auf und hört unabhàngig
vom Frontend auf.

Wenn ich die selben Musikstücke mit Totem anhöre, treten all diese
Effekte (incl. der dumpferen Wiedergabe) nicht auf.

Meine mpd.conf:

jakob@pluto $ cat /etc/mpd.conf|grep -v '^#'|sed '/^$/d'
music_directory "/var/lib/mpd/music"
playlist_directory "/var/lib/mpd/playlists"
db_file "/var/lib/mpd/tag_cache"
log_file "/var/log/mpd/mpd.log"
error_file "/var/log/mpd/errors.log"
pid_file "/var/run/mpd/pid"
state_file "/var/lib/mpd/state"
user "mpd"
log_level "verbose"
audio_output {
type "ao"
driver "default"
name "esd-default"
}
audio_output {
type "ao"
options "host7.0.0.1"
name "esd"
}
mixer_type "alsa"
mixer_device "mpdvol"
mixer_control "MPD PCM"
audio_buffer_size "4096"
buffer_before_play "50%"
filesystem_charset "UTF-8"
id3v1_encoding "UTF-8"
metadata_to_use
"artist,album,title,track,name,genre,date,composer,performer,disc"
save_absolute_paths_in_playlists "yes"

Mein System ist ein aktuelles Debian Lenny.

Fàllt jemandem dazu was ein (ev. auch eine besser passende Gruppe)?

lg jakob

The UNIX way of Sex:
gunzip-strip-touch-finger-mount-fsck-more-yes-umount-sleep
 

Lesen sie die antworten

#1 Andreas Wagner
28/03/2009 - 09:42 | Warnen spam
Am Thu, 26 Mar 2009 21:28:36 +0100 schrieb Jakobus Schürz:

Hallo Gemeinde.



Hallo Jakobus!

Wieder einmal macht mein mpd nicht das was er soll.

Erstens ist mir aufgefallen, dass der mpd immer gleich 3 Instanzen
startet. "ps auxf" zeigt diese drei Instanzen als Mutter, Kind und
Enkel. Alle Drei zeigen "/usr/bin/mpd /etc/mpd.conf" Warum reicht da
nicht eine einzige?



Macht er bei mir auch, ist wohl normal.

Ok, ich weiß nicht, ob das die Ursache für mein Problem ist. Wenn ich
Musik höre, dann klingt die dumpf und ab und zu hört es sich an, als ob
ein Altes Radio in ein laaanges Kanalrohr gestellt würde. Echoeffekte
und Soundeffekte wie eben die Wiedergabe in einem langen Rohr. Anders
kann ich das nicht treffender beschreiben.



Klingt, als wàre da das Signal zweimal drin, geringfügig zeitversetzt.
Damit werden dann manche Frequenzen verstàrkt und manche abgeschwàcht.

Manchmal tritt das auf, wenn ich ein Frontend start und hört auf, wenn
ich das Frontend schließe, manchmal tritt es auf und hört unabhàngig vom
Frontend auf.



Da àndert sich glaube ich nur der Zeitversatz.

Wenn ich die selben Musikstücke mit Totem anhöre, treten all diese
Effekte (incl. der dumpferen Wiedergabe) nicht auf.

Meine mpd.conf:

[..]
audio_output {
type "ao"
driver "default"
name "esd-default"
}
audio_output {
type "ao"
options "host7.0.0.1"
name "esd"
}



Japp, gratuliere, du hast mit mpd einen Kammfilter gebaut! :-) Habe ich
gerade mal nachgebaut und nicht schlecht gestaunt...

[..]

Mein System ist ein aktuelles Debian Lenny.

Fàllt jemandem dazu was ein (ev. auch eine besser passende Gruppe)?



Ja: Einen der beiden audio_output-Bereiche löschen, oder mit »mpc disable
1« einen Kanal stummschalten.

lg jakob



Gruß
Andreas

Ähnliche fragen