MPIO

08/09/2009 - 22:06 von Andreas Altermann | Report spam
Hi NG,

.. und hoffentlich ist Bernd aus dem Urlaub gesund zurück :-)

Gibt es ein How to Do - wie ich MPIO einrichte auf einem 2 Node Cluster mit
WSS2008 SAN der auch als ISCSi_Target dient ?

Habe pro Geràt zwei Intel-Nics frei.

Gruß
Andreas Altermann
 

Lesen sie die antworten

#1 Bernd Pfann [MS]
09/09/2009 - 22:12 | Warnen spam
"Andreas Altermann" wrote in message
news:uksPk$
Hi NG,

.. und hoffentlich ist Bernd aus dem Urlaub gesund zurück :-)


Eigentlich erst ab Montag - bin aber gerade heute mal da ...

Gibt es ein How to Do - wie ich MPIO einrichte auf einem 2 Node Cluster
mit
WSS2008 SAN der auch als ISCSi_Target dient ?


MPIO dient dazu mehrere Pfade von einem Server zu einem Storage System
zusammen zu fassen, bzw. zu verwalten. Damit man MPIO verwenden kann ist
also mehr als ein Pfad notwendig. Durch die beiden Intel NICs ist diese
Voraussetzung schon mal gegeben. Die Konfiguration làuft wie folgt
(exemplarisch):

Server 1 / Intel NIC 1: 10.0.1.11/24
Server 1 / Intel NIC 2: 10.0.2.11/24

Storage Server NIC 1: 10.0.1.10/24
Storage Server NIC 2: 10.0.2.10/24

Durch die Verwendung von zwei IP-Subnetzen sieht der Server 1 den Storage
Server 2x.

Nun muss der Initiator auf dem Server 1 konfiguriert werden.
Dazu ist 2x ein Login auf dem Storage Server (Target) notwendig und das geht
wie folgt:

iSCSI Initiator Properties/Discovery
-> Discover Portal/Discover Target Portal
Hier die erste IP des Storage Server (10.0.1.10) eingeben und dann auf
Advanced clicken - hier wird nun unter Initiator IP die IP gewàhlt welche im
Subnetz liegt (10.0.1.11)

Das alles für das 2te Subnetz wiederholen, also 10.0.2.10 und 10.0.2.11

Nach einem erfolgreichen Login sind die LUNs DOPPELT vorhanden - das ist der
Beweis das der Initiator/Server den Target über zwei Pfade sieht. Sollte das
nicht der Fall sein, ist vorher was schief gelaufen.

Sind nun die LUNs doppelt da, wird MPIO verwendet um diese zusammen zu
fassen:

Dazu MPIO als Feature installieren und aufrufen. Im Reiter Discover
Multi-Paths die Option "Add support for iSCSI devices" aktivieren. Danach
muss der Server neu gestartet werden und die LUNs sind nur noch EINFACH
vorhanden.

Das wars ;-) eigentlich würde ich einen Blog oder sowas brauchen um das mit
ein paar Screenshoots zu hinterlegen. Ich hoffe es geht auch so.

Ich bin dann wieder bis Sonntag in den Bergen und vorausgesetzt ich hagel
beim Klettern nicht runter, am Montag "offiziell" wieder verfügbar.
Mit freundlichen Grüßen / Kind regards - Bernd Pfann (Microsoft)

This posting is provided "AS IS" with no warranties, and confers no
rights.

Ähnliche fragen