[mplayer] Too many audio packets in the buffer

11/09/2010 - 11:52 von Markus Wichmann | Report spam
Hi all,

ich wollte dieses Video hier mir mal angucken:

<http://web.cecs.pdx.edu/~harry/Relay/VideoTutorial/SupportingFiles/Video640x480.mov>
356 MB, .mov/H.264/AAC

Nur hab ich da folgende Probleme: Das OSD wird so ca. alle 10 Sekunden
aktualisiert, was dazu führt, dass Tastendrücke auf "o" erst viel spàter
bearbeitet werden. Spulen ist in dieser Datei auch witzig, es scheint
beim zurückspulen unüberwindbare Barrieren zu geben. Aber das schlimmste
ist, dass die Wiedergabe nach 12:30 bei mir mit der im Subject genannten
Fehlermeldung abbricht. Starte ich die Wiedergabe mit "-ss 12:40"
erneut, bricht das ganze eben bei 17:nochwas ab. Was kann ich tun?

Erfolglos versucht bislang:

Neu kodieren als avi:

$ mencoder -oac lavc -ovc lavc -o tmp.avi Video640x480.mov
Too many audio packets in the buffer. (Nachdem 46 Sekunden enkodiert
sind)

$ mplayer -ao pcm:fast:file=tmp.wav -vc null -vo null Video640x480.mov
Too many [naja, ihr kennt den Text] (Nach 1 Sekunde. Die Wave-Datei ist
genau 65580 Bytes groß. Zieht man den "canonical wave header" von IIRC
44 Bytes ab, kommt man bei 65536 Bytes heraus. Deutungen?)

$ mplayer -dumpstream -dumpfile tmp.aac Video640x480.mov
$ echo 'Hurra, es geht doch etwas!' > /dev/null
$ faad tmp.aac
$ echo 'Hurra, es geht noch mal etwas!' > /dev/null
$ mplayer -audiofile tmp.wav Video640x480.mov
$ echo 'Och nö, mit "-audiofile" kann man nicht seeken, aber die ersten
17 min kenn ich doch schon! Davon abgesehen A/V-Desync, der immer
schlimmer wird.' >/dev/null

Erfolglos probierte Optionen:
Zu mplayer:
-mc 0

Zu mencoder:
-mc 0 -noskip
-ofps 25

Hat jemand Ahnung, was ich noch versuchen könnte?

System:
Hardware:
Thinkpad T61
= Intel Core 2 Duo,
Intel GM965 Grafikchip,
Intel 82801H Soundchip
Software:
Debian Squeeze
mplayer SVN-r31918

Tschö,
Markus
 

Lesen sie die antworten

#1 Heiko Nocon
11/09/2010 - 14:37 | Warnen spam
Markus Wichmann wrote:

Erfolglos versucht bislang:


[...]


Ich hab' einfach VLC als Player genommen und gut war. Lineares Abspielen
völlig problemlos und sogar die Navigation funktioniert einigermaßen
(Ton startet sofort an der richtigen Stelle, Bild mit unterschiedlicher
Verzögerung, vermutlich immer mit dem jeweils nàchsten I-Frame).

Ähnliche fragen